aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-08-23 21:10:57 +0800
committerKris Kennaway <kris@FreeBSD.org>2001-08-23 21:10:57 +0800
commit0ceeb37c93fe7b2b0363a7a26bc680a4cf15d05c (patch)
tree0a8927910be21d9dba982fcb2c7198de23068724 /net
parent84f833647ba478fd29fc3f0fb5cec9f727611518 (diff)
downloadfreebsd-ports-0ceeb37c93fe7b2b0363a7a26bc680a4cf15d05c.tar.gz
freebsd-ports-0ceeb37c93fe7b2b0363a7a26bc680a4cf15d05c.tar.zst
freebsd-ports-0ceeb37c93fe7b2b0363a7a26bc680a4cf15d05c.zip
Add xprobe-0.0.1p1
Xprobe is a tool automating the X logic. X is a logic developed from the various Active Operating System Fingerprinting methods discovered during the "ICMP Usage In Scanning" research project. Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=46712
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/xprobe/Makefile19
-rw-r--r--net/xprobe/distinfo1
-rw-r--r--net/xprobe/files/patch-Makefile_in45
-rw-r--r--net/xprobe/files/patch-configure11
-rw-r--r--net/xprobe/pkg-comment1
-rw-r--r--net/xprobe/pkg-descr7
-rw-r--r--net/xprobe/pkg-plist1
8 files changed, 86 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ca98826d25d0..f962732500e6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -424,6 +424,7 @@
SUBDIR += xisp
SUBDIR += xmlrpc-c
SUBDIR += xsmbrowser
+ SUBDIR += xprobe
SUBDIR += xtraceroute
SUBDIR += xtradius
SUBDIR += xwhois
diff --git a/net/xprobe/Makefile b/net/xprobe/Makefile
new file mode 100644
index 000000000000..7633e4b7a5d1
--- /dev/null
+++ b/net/xprobe/Makefile
@@ -0,0 +1,19 @@
+# Ports collection makefile for: xprobe
+# Date created: 23 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xprobe
+PORTVERSION= 0.0.1p1
+CATEGORIES= net security
+MASTER_SITES= http://www.sys-security.com/archive/tools/X/
+
+MAINTAINER= kris@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+MAN1= xprobe.1
+
+.include <bsd.port.mk>
diff --git a/net/xprobe/distinfo b/net/xprobe/distinfo
new file mode 100644
index 000000000000..6c91fb8225df
--- /dev/null
+++ b/net/xprobe/distinfo
@@ -0,0 +1 @@
+MD5 (xprobe-0.0.1p1.tar.gz) = a94fa330d0ca1bfc09e327f628d1e682
diff --git a/net/xprobe/files/patch-Makefile_in b/net/xprobe/files/patch-Makefile_in
new file mode 100644
index 000000000000..2d6a9504792f
--- /dev/null
+++ b/net/xprobe/files/patch-Makefile_in
@@ -0,0 +1,45 @@
+--- Makefile.in.orig Wed Jul 25 18:55:30 2001
++++ Makefile.in Wed Jul 25 18:59:54 2001
+@@ -21,12 +21,16 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+
++DESTDIR=
++
+ CC=@CC@
+ INSTALL=@INSTALL@
++INSTALL_PROGRAM=@INSTALL_PROGRAM@
++INSTALL_DATA=@INSTALL_DATA@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-bindir=@bindir@
+-mandir=@mandir@
++BINDIR=@bindir@
++MANDIR=@mandir@
+ PACKAGE=@PACKAGE@
+ VERSION=@VERSION@
+ CPPFLAGS=@CPPFLAGS@
+@@ -41,7 +45,9 @@ icmp_infr.o utils.o logic_tree.o pcap_if
+ FILES=$(SOURCES) $(INCLUDES) AUTHORS CREDITS Changelog LICENSE Makefile.in \
+ README TODO config.h.in configure configure.in cfg-scripts xprobe.1
+
+-x: $(OBJS)
++all: xprobe
++
++xprobe: $(OBJS)
+ $(CC) $(CFLAGS) $(OBJS) -o $@ $(LDFLAGS) $(LIBS)
+
+ .c.o: $(INCLUDES)
+@@ -52,9 +58,9 @@ clean:
+ distclean: clean
+ rm -f config.h config.cache config.log config.status Makefile
+
+-install: x
+- $(INSTALL) -m 0755 -g bin -o root x $(bindir)
+- $(INSTALL) -m 0444 -g bin -o root xprobe.1 $(mandir)/man1
++install: xprobe
++ $(INSTALL_PROGRAM) -m 755 xprobe $(DESTDIR)$(BINDIR)
++ $(INSTALL_DATA) xprobe.1 $(DESTDIR)$(MANDIR)/man1
+
+ configure: configure.in
+ autoheader
diff --git a/net/xprobe/files/patch-configure b/net/xprobe/files/patch-configure
new file mode 100644
index 000000000000..9acbddbca8d7
--- /dev/null
+++ b/net/xprobe/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jul 24 19:32:54 2001
++++ configure Tue Jul 24 19:33:09 2001
+@@ -9,7 +9,7 @@
+
+ # Defaults:
+ ac_help=
+-ac_default_prefix=/usr/local
++ac_default_prefix=${LOCALBASE}
+ # Any additions from configure.in:
+ ac_help="$ac_help
+ --enable-debug enable debugging )"
diff --git a/net/xprobe/pkg-comment b/net/xprobe/pkg-comment
new file mode 100644
index 000000000000..8f95e563aa59
--- /dev/null
+++ b/net/xprobe/pkg-comment
@@ -0,0 +1 @@
+ICMP active OS fingerprint scanner
diff --git a/net/xprobe/pkg-descr b/net/xprobe/pkg-descr
new file mode 100644
index 000000000000..8c1e81ae1843
--- /dev/null
+++ b/net/xprobe/pkg-descr
@@ -0,0 +1,7 @@
+Xprobe is a tool automating the X logic.
+
+X is a logic developed from the various Active Operating System
+Fingerprinting methods discovered during the "ICMP Usage In
+Scanning" research project.
+
+WWW: http://www.sys-security.com/html/projects/X.html
diff --git a/net/xprobe/pkg-plist b/net/xprobe/pkg-plist
new file mode 100644
index 000000000000..556692303d11
--- /dev/null
+++ b/net/xprobe/pkg-plist
@@ -0,0 +1 @@
+bin/xprobe