aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-05 20:17:08 +0800
committerWill Andrews <will@FreeBSD.org>2001-03-05 20:17:08 +0800
commit34849535bebfc5c5d005eca7cd0f98a370f72b8f (patch)
treee128e75ec713570fee1d10d4741e8f3ee842bcd9 /net
parent7f69652b20076b42f78d474a9b090aff3c2d59b2 (diff)
downloadfreebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.tar.gz
freebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.tar.zst
freebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.zip
Attempt to fix conflicts with a local getopt.h (specifically, the fix is
for libgnugetopt's getopt.h). Not tested, but should work.
Notes
Notes: svn path=/head/; revision=39086
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork2/Makefile2
-rw-r--r--net/kdenetwork3/Makefile2
-rw-r--r--net/kdenetwork4/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/kdenetwork2/Makefile b/net/kdenetwork2/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork2/Makefile
+++ b/net/kdenetwork2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index c80ace0cbddb..1847c939eb92 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_XOPEN_UNIX" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes