aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-05-16 18:25:45 +0800
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-05-16 18:25:45 +0800
commitd2f7d92dca0d054f5ac448e1af87ddc24a8ba9ae (patch)
tree55fccea89bc0d899fc7230b6e46bacbcf0b13142 /net
parentb48db9367cdfd132be488a08791340c0f995432d (diff)
downloadfreebsd-ports-d2f7d92dca0d054f5ac448e1af87ddc24a8ba9ae.tar.gz
freebsd-ports-d2f7d92dca0d054f5ac448e1af87ddc24a8ba9ae.tar.zst
freebsd-ports-d2f7d92dca0d054f5ac448e1af87ddc24a8ba9ae.zip
Add new ports.
PR: ports/37661 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Approved by: knu (mentor)
Notes
Notes: svn path=/head/; revision=59248
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/lmd/Makefile42
2 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 18d6f12fca68..0e8f3262f417 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -231,6 +231,7 @@
SUBDIR += linpopup
SUBDIR += linux-edonkey-server
SUBDIR += lla
+ SUBDIR += lmd
SUBDIR += macipgw
SUBDIR += maradns
SUBDIR += mars_nwe
diff --git a/net/lmd/Makefile b/net/lmd/Makefile
new file mode 100644
index 000000000000..1cf69392eec3
--- /dev/null
+++ b/net/lmd/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lmd
+# Date created: Thu May 2 11:20:06 CET 2002
+# Whom: Alex Dupre <sysadmin@alexdupre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lmd
+PORTVERSION= 0.8
+CATEGORIES= net sysutils
+MASTER_SITES= http://www.bsdshell.net/download/
+
+MAINTAINER= sysadmin@alexdupre.com
+
+MODULES= ldd_http_module.so
+DOCS= INSTALL LICENSE README
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
+
+post-build:
+ @${SED} 's,%PREFIX%,${PREFIX},g' ${.CURDIR}/pkg-message.in \
+ > ${WRKDIR}/pkg-message
+
+do-install:
+ @${ECHO_CMD} "Installing files..."
+ @${INSTALL_PROGRAM} ${WRKSRC}/lmd ${PREFIX}/sbin/lmd
+ @${INSTALL_DATA} ${WRKSRC}/lmd.conf ${PREFIX}/etc/lmd.conf.sample
+.for f in ${MODULES}
+ @${INSTALL_DATA} ${WRKSRC}/modules_check/${f} ${PREFIX}/lib/
+.endfor
+ @${CAT} ${PKGMESSAGE}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>