aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-07 01:59:31 +0800
committerpav <pav@FreeBSD.org>2009-01-07 01:59:31 +0800
commit8ef21a396d8627cdfced24744c2bacb7cb0c9453 (patch)
tree06fbb407306ac7e1b7b00946df69737e787c8891 /news
parente32973556a174646ad93cdf1b43963a9fc18eb55 (diff)
downloadfreebsd-ports-8ef21a396d8627cdfced24744c2bacb7cb0c9453.tar.gz
freebsd-ports-8ef21a396d8627cdfced24744c2bacb7cb0c9453.tar.zst
freebsd-ports-8ef21a396d8627cdfced24744c2bacb7cb0c9453.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'news')
-rw-r--r--news/hellanzb/Makefile4
-rw-r--r--news/nntpswitch/Makefile7
2 files changed, 3 insertions, 8 deletions
diff --git a/news/hellanzb/Makefile b/news/hellanzb/Makefile
index b358194789c2..702657b3208f 100644
--- a/news/hellanzb/Makefile
+++ b/news/hellanzb/Makefile
@@ -28,8 +28,8 @@ USE_PYDISTUTILS=yes
.include <bsd.port.pre.mk>
-# more fully-featured rar needs at least 5.3
-.if ${ARCH} == "i386" && ${OSVERSION} >= 503000
+# more fully-featured rar needs i386
+.if ${ARCH} == "i386"
RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
.else
RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
diff --git a/news/nntpswitch/Makefile b/news/nntpswitch/Makefile
index 24d1b030d609..6e20de914091 100644
--- a/news/nntpswitch/Makefile
+++ b/news/nntpswitch/Makefile
@@ -54,11 +54,6 @@ ALL_TARGET+= ldap
PLIST_FILES+= lib/${PORTNAME}/auth_ldap.so
.endif
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500029
-BROKEN= "${PORTNAME} requires atoll(3)"
-.endif
-
do-configure:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/nntpswitch.conf.in
@@ -70,4 +65,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/nntpswitch.conf-dist ${ETC_DIR}/
${INSTALL_SCRIPT} ${FILESDIR}/nntpswitch.sh ${PREFIX}/etc/rc.d/nntpswitch.sh-dist
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>