aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2009-11-27 23:45:56 +0800
committerfluffy <fluffy@FreeBSD.org>2009-11-27 23:45:56 +0800
commitc6a2ac48df0ca52b6f6faa1409b8b1fc771db5de (patch)
treebe64621d01d192096c689984b8ac9b58b7f8154b /news
parentcb68080432abf5113bdcbb05cf214b5e809d0dc6 (diff)
downloadfreebsd-ports-c6a2ac48df0ca52b6f6faa1409b8b1fc771db5de.tar.gz
freebsd-ports-c6a2ac48df0ca52b6f6faa1409b8b1fc771db5de.tar.zst
freebsd-ports-c6a2ac48df0ca52b6f6faa1409b8b1fc771db5de.zip
- Make perl5 dependency mandatory [1]
- Improve tcl handling Noticed by: dinoex via IRC [1] Approved by: tabthorpe (co-mentor)
Diffstat (limited to 'news')
-rw-r--r--news/inn/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index f6ccd5f91d1b..af1a6e273ccd 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= inn
PORTVERSION?= 2.4.6
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= news ipv6
MASTER_SITES?= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR?= ${PORTNAME}
@@ -22,14 +22,13 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_GMAKE= yes
USE_OPENSSL= yes
-WANT_PERL= yes
+USE_PERL5= yes
CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
BRANCH?= # Empty
-OPTIONS= PERL "Embedded Perl script support" On \
- PYTHON "Embedded Python module support" Off \
+OPTIONS= PYTHON "Embedded Python module support" Off \
TCL "Embedded TCL support" Off \
KERBEROS "Enable Kerberos auth support" Off \
SASL "Enable SASL support (for imapfeed auth)" Off \
@@ -54,7 +53,7 @@ CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
--with-run-dir=${INN_RUNDIR} \
--with-db-dir=${INN_DBDIR} \
--with-ssl=${OPENSSLBASE} \
- --enable-ipv6
+ --enable-ipv6 --with-perl
.include <bsd.port.options.mk>
@@ -78,11 +77,6 @@ CONFIGURE_ENV+= ac_cv_func_krb5_init_ets=yes
CONFIGURE_ARGS+= --without-kerberos
.endif
-.if !defined(WITHOUT_PERL)
-USE_PERL5= yes
-CONFIGURE_ARGS+= --with-perl
-.endif
-
.if defined(WITH_PYTHON)
USE_PYTHON= YES
CONFIGURE_ARGS+= --with-python
@@ -90,7 +84,7 @@ CONFIGURE_ARGS+= --with-python
.endif
.if defined(WITH_TCL)
-USE_TCL= 84
+USE_TCL= 84+
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}
.endif
@@ -193,8 +187,8 @@ post-patch:
@${REINPLACE_CMD} -E 's!\$$[{(]PATHETC[})]!${EXAMPLESDIR}!g' \
${WRKSRC}/site/Makefile
.if defined(WITH_TCL)
- @${REINPLACE_CMD} -e 's!<tcl.h>!<tcl8.4/tcl.h>!' ${WRKSRC}/innd/innd.h
- @${REINPLACE_CMD} -e 's!-ltcl!-ltcl84!' \
+ @${REINPLACE_CMD} -e 's!<tcl.h>!<tcl${TCL_VER}/tcl.h>!' ${WRKSRC}/innd/innd.h
+ @${REINPLACE_CMD} -e 's!-ltcl!-ltcl${USE_TCL}!' \
${WRKSRC}/configure
.endif
@${REINPLACE_CMD} -e 's!et/com_err\.h!com_err.h!g' \