aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-03-28 17:50:40 +0800
committerDmitry Sivachenko <demon@FreeBSD.org>2001-03-28 17:50:40 +0800
commit378988c9ad0b34e0f431df6b3a2534c2df32c36a (patch)
treed5d2843ca1dc3a918b026b97786e879dd11a025b /print
parent7c95143f4f9b4dec59d797fa718ebf1dfc366bf1 (diff)
downloadfreebsd-ports-378988c9ad0b34e0f431df6b3a2534c2df32c36a.tar.gz
freebsd-ports-378988c9ad0b34e0f431df6b3a2534c2df32c36a.tar.zst
freebsd-ports-378988c9ad0b34e0f431df6b3a2534c2df32c36a.zip
New port: ktexshell.
KDE frontend to the popular TeX/LaTeX typesetting system
Notes
Notes: svn path=/head/; revision=40468
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/ktexshell/Makefile34
-rw-r--r--print/ktexshell/distinfo1
-rw-r--r--print/ktexshell/pkg-comment1
-rw-r--r--print/ktexshell/pkg-descr21
-rw-r--r--print/ktexshell/pkg-plist11
6 files changed, 69 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 0d9455a809a7..5d0ab13cd0fb 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -58,6 +58,7 @@
SUBDIR += ifhp
SUBDIR += jadetex
SUBDIR += klyx
+ SUBDIR += ktexshell
SUBDIR += latex
SUBDIR += latex2rtf
SUBDIR += lilypond
diff --git a/print/ktexshell/Makefile b/print/ktexshell/Makefile
new file mode 100644
index 000000000000..2ec63d61ec5a
--- /dev/null
+++ b/print/ktexshell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ktexshell
+# Date created: 28 March 2001
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ktexshell
+PORTVERSION= 0.4.0
+CATEGORIES= print kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ktexshell
+
+MAINTAINER= demon@FreeBSD.org
+
+LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2 \
+ intl.1:${PORTSDIR}/devel/gettext
+
+USE_QT2= yes
+MOC?= ${X11BASE}/bin/moc2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-extra-libs=${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+ MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
+
+post-patch:
+ @${PERL} -pi -e 's#libqt#libqt2#g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's#lqt#lqt2#g' ${WRKSRC}/configure ${WRKSRC}/ktexshell/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/print/ktexshell/distinfo b/print/ktexshell/distinfo
new file mode 100644
index 000000000000..d016cde1a8ab
--- /dev/null
+++ b/print/ktexshell/distinfo
@@ -0,0 +1 @@
+MD5 (ktexshell-0.4.0.tar.gz) = 01efe2f8252f8f72e7d6f0f33ec239e7
diff --git a/print/ktexshell/pkg-comment b/print/ktexshell/pkg-comment
new file mode 100644
index 000000000000..1cd216c84470
--- /dev/null
+++ b/print/ktexshell/pkg-comment
@@ -0,0 +1 @@
+KDE frontend to the popular TeX/LaTeX typesetting system
diff --git a/print/ktexshell/pkg-descr b/print/ktexshell/pkg-descr
new file mode 100644
index 000000000000..209f27e1dc2a
--- /dev/null
+++ b/print/ktexshell/pkg-descr
@@ -0,0 +1,21 @@
+KTeXShell is a KDE frontend to the popular TeX/LaTeX-
+typesetting system. The indended audience is the difference
+between all (explicit and implicit) TeX-users and the users
+of tools like LyX or KLyX. That means: KTeXShell does
+only provide a frontend to TeX and the related programs,
+while the user has to keep on coding his documents in the
+TeX language. In other words: This is for TeX hackers.
+
+Some Features:
+--------------
+
+- TeX, Editor, Viewer... are called from menu or toolbar
+- new primary files can be generated from templates
+- TeX formats, editors and viewers can be configured as well
+ as template- and working directory
+- in case of TeX errors, an error handling dialog helps you
+ to proceed
+- Integrated tools: at present we have makeindex and a generic
+ dvips-call (for printing)
+
+WWW: http://ktexshell.sourceforge.net/
diff --git a/print/ktexshell/pkg-plist b/print/ktexshell/pkg-plist
new file mode 100644
index 000000000000..98d6ffa8e291
--- /dev/null
+++ b/print/ktexshell/pkg-plist
@@ -0,0 +1,11 @@
+bin/ktexshell
+share/doc/HTML/en/ktexshell/index.html
+share/doc/HTML/en/ktexshell/index-1.html
+share/doc/HTML/en/ktexshell/index-2.html
+share/doc/HTML/en/ktexshell/index-3.html
+share/doc/HTML/en/ktexshell/index-4.html
+share/doc/HTML/en/ktexshell/index-5.html
+share/doc/HTML/en/ktexshell/index-6.html
+share/doc/HTML/en/ktexshell/logotp3.png
+share/applnk/Applications/ktexshell.kdelnk
+@dirrm share/doc/HTML/en/ktexshell