aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-25 03:50:53 +0800
committerThierry Thomas <thierry@FreeBSD.org>2006-04-25 03:50:53 +0800
commit50542d86ac1081aa1a87dfa884b8490fc209dfbe (patch)
tree9c97d2d9b191da278780d20f7ab7c38a07516e06 /science
parentfaa30fab34dd5c74a2cf0867b71bb496d137524e (diff)
downloadfreebsd-ports-50542d86ac1081aa1a87dfa884b8490fc209dfbe.tar.gz
freebsd-ports-50542d86ac1081aa1a87dfa884b8490fc209dfbe.tar.zst
freebsd-ports-50542d86ac1081aa1a87dfa884b8490fc209dfbe.zip
MATC language library used by Elmer FEM package.
Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=160353
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmer-matc/Makefile37
-rw-r--r--science/elmer-matc/distinfo3
-rw-r--r--science/elmer-matc/pkg-descr3
-rw-r--r--science/elmer-matc/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 02ea0612527a..85520c0f9240 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -18,6 +18,7 @@
SUBDIR += devisor
SUBDIR += dft++
SUBDIR += elmer-eio
+ SUBDIR += elmer-matc
SUBDIR += elmer-meshgen2d
SUBDIR += elmergrid
SUBDIR += euler
diff --git a/science/elmer-matc/Makefile b/science/elmer-matc/Makefile
new file mode 100644
index 000000000000..924d9ddb4fb9
--- /dev/null
+++ b/science/elmer-matc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Elmer-MatC
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= matc
+PORTVERSION= 5.0.0
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= MatC language library used by ELMER FEM package
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran
+
+USE_GCC= 4.1+
+WITH_FORTRAN= yes
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+CONFIGURE_ENV+= FC=${FC} F77=${FC}
+
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+PLIST_SUB= ARCH=${MACHINE_ARCH}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+FFLAGS+= -fPIC
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/elmer-matc/distinfo b/science/elmer-matc/distinfo
new file mode 100644
index 000000000000..21dcec4b3ef4
--- /dev/null
+++ b/science/elmer-matc/distinfo
@@ -0,0 +1,3 @@
+MD5 (matc-5.0.0.tar.gz) = 24449bde04aab5958f05f76dc8855471
+SHA256 (matc-5.0.0.tar.gz) = ff8752b764575090682363ae43cb7ace02fc06c79a19bad69bf74ed1d81ce338
+SIZE (matc-5.0.0.tar.gz) = 165330
diff --git a/science/elmer-matc/pkg-descr b/science/elmer-matc/pkg-descr
new file mode 100644
index 000000000000..919f3ab45ff3
--- /dev/null
+++ b/science/elmer-matc/pkg-descr
@@ -0,0 +1,3 @@
+MATC language library used by Elmer FEM package.
+
+WWW: http://www.csc.fi/elmer/
diff --git a/science/elmer-matc/pkg-plist b/science/elmer-matc/pkg-plist
new file mode 100644
index 000000000000..ec1b9ea861b2
--- /dev/null
+++ b/science/elmer-matc/pkg-plist
@@ -0,0 +1,6 @@
+bin/%%ARCH%%-portbld-freebsd%%OSREL%%-matc
+include/elmer/fnames.h
+include/elmer/gra.h
+include/elmer/matc.h
+@dirrm include/elmer
+lib/libmatc.a