aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnupg-idea/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-06 14:42:01 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-06 14:42:01 +0800
commit0635dc2c2130ed0c0c80123f31c9e27afd91fa49 (patch)
treebe71e29ac39140c79503011595111ee00e67e4f1 /security/gnupg-idea/Makefile
parentd78bea81950e6a8bb706a49366237666ffd14faf (diff)
downloadfreebsd-ports-0635dc2c2130ed0c0c80123f31c9e27afd91fa49.tar.gz
freebsd-ports-0635dc2c2130ed0c0c80123f31c9e27afd91fa49.tar.zst
freebsd-ports-0635dc2c2130ed0c0c80123f31c9e27afd91fa49.zip
Fix the port.
- Remove extra spaces and newlines - Describe RESTRICTED more specifically - Generate PLIST on the fly - Prepare PKGMESSAGE to inform the users (Additional fixes by knu follow:) - Add MASTER_SITES. - Respect MAKE_IDEA that could be defined in /etc/make.conf - Make a bit more portlint friendly - Fix pkg-{comment,descr} to reflect the latest situation gnupg-idea was repo-moved from gnupg-rsa, because now GnuPG has a builtin RSA support. (GnuPG >= 1.03, after the RSA patent restriction was lifted) PR: ports/22620 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=34828
Diffstat (limited to 'security/gnupg-idea/Makefile')
-rw-r--r--security/gnupg-idea/Makefile34
1 files changed, 20 insertions, 14 deletions
diff --git a/security/gnupg-idea/Makefile b/security/gnupg-idea/Makefile
index bb6ae34b4699..5934f7d70536 100644
--- a/security/gnupg-idea/Makefile
+++ b/security/gnupg-idea/Makefile
@@ -1,24 +1,30 @@
-# New ports collection makefile for: gnupg-rsa
-# Date created: 10 May, 2000
+# New ports collection makefile for: gnupg-idea
+# Date created: 10 May, 2000
# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
#
-PORTNAME= gnupg-rsa
+PORTNAME= gnupg-idea
PORTVERSION= 1.0.1
-PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= ftp://ftp.gnupg.org/pub/gcrypt/contrib/
+MASTER_SITES= ftp://ftp.gnupg.org/pub/gcrypt/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/gnupg/&,}
+MASTER_SITE_SUBDIR= contrib
+DISTFILES= ${CONTRIB:S|$|.c|}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= # none
MAINTAINER= dirk.meyer@dinoex.sub.org
-RESTRICTED= "Crypto; export-controlled"
RUN_DEPENDS= ${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg
+
+RESTRICTED= "IDEA is Patented in the USA and many European countries"
+
NO_WRKSUBDIR= yes
-DIST_SUBDIR= ${PORTNAME}
CFLAGS+= -O2 -shared -fPIC -DIS_MODULE
CFLAGS+= -Wall -Wcast-align -Wshadow -Wstrict-prototypes
+PLIST= ${WRKDIR}/.PLIST.more
.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@@ -31,19 +37,18 @@ pre-fetch:
.elif defined(USA_RESIDENT)
-.if ${USA_RESIDENT} == NO
-DISTFILES= rsa.c idea.c
-CONTRIB= rsa idea
+.if ${USA_RESIDENT} == NO || defined(MAKE_IDEA)
+CONTRIB= idea rsa
.else
-DISTFILES= rsa.c
CONTRIB= rsa
.endif
.include <bsd.port.pre.mk>
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
+pre-extract:
+ @${SED} s!%%PREFIX%%!${PREFIX}!g ${PKGMESSAGE}
+
+post-extract:
.for i in ${DISTFILES}
@${CP} ${_DISTDIR}/${i} ${WRKSRC}/${i}
.endfor
@@ -57,6 +62,7 @@ do-patch:
do-build:
.for i in ${CONTRIB}
${CC} ${CFLAGS} -o ${WRKSRC}/${i} ${WRKSRC}/${i}.c
+ ${ECHO} "lib/gnupg/${i}" >>${PLIST}
.endfor
do-install: