aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2004-01-26 06:08:27 +0800
committercy <cy@FreeBSD.org>2004-01-26 06:08:27 +0800
commitb3648e9e8bff8bb8c52c9d9c8c397eb531b6e22a (patch)
tree48165d8dbb4f562b68f2ce3f2fc91154fe9792e0 /security
parent4e93ca2298d6e9a3c1457c87aec1c9d3126cd948 (diff)
downloadfreebsd-ports-b3648e9e8bff8bb8c52c9d9c8c397eb531b6e22a.tar.gz
freebsd-ports-b3648e9e8bff8bb8c52c9d9c8c397eb531b6e22a.tar.zst
freebsd-ports-b3648e9e8bff8bb8c52c9d9c8c397eb531b6e22a.zip
Change to src/include/netdb.h 1.31 caused a compile error. This
commit fixes that error. Reported by: bento
Diffstat (limited to 'security')
-rw-r--r--security/krb5-16/Makefile2
-rw-r--r--security/krb5-16/files/patch-lib::krb5::os::hst_realm.c14
-rw-r--r--security/krb5-16/files/patch-lib::krb5::os::locate_kdc.c13
-rw-r--r--security/krb5-17/Makefile2
-rw-r--r--security/krb5-17/files/patch-lib::krb5::os::hst_realm.c14
-rw-r--r--security/krb5-17/files/patch-lib::krb5::os::locate_kdc.c13
-rw-r--r--security/krb5-appl/Makefile2
-rw-r--r--security/krb5-appl/files/patch-lib::krb5::os::hst_realm.c14
-rw-r--r--security/krb5-appl/files/patch-lib::krb5::os::locate_kdc.c13
-rw-r--r--security/krb5/Makefile2
-rw-r--r--security/krb5/files/patch-lib::krb5::os::hst_realm.c14
-rw-r--r--security/krb5/files/patch-lib::krb5::os::locate_kdc.c13
12 files changed, 112 insertions, 4 deletions
diff --git a/security/krb5-16/Makefile b/security/krb5-16/Makefile
index 09194e6cc737..6c19574c3837 100644
--- a/security/krb5-16/Makefile
+++ b/security/krb5-16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-16/files/patch-lib::krb5::os::hst_realm.c b/security/krb5-16/files/patch-lib::krb5::os::hst_realm.c
new file mode 100644
index 000000000000..d3caed59fd30
--- /dev/null
+++ b/security/krb5-16/files/patch-lib::krb5::os::hst_realm.c
@@ -0,0 +1,14 @@
+--- lib/krb5/os/hst_realm.c.orig Tue Oct 15 15:51:50 2002
++++ lib/krb5/os/hst_realm.c Sat Jan 24 20:11:05 2004
+@@ -438,9 +438,11 @@
+ return EAFNOSUPPORT;
+ case EAI_MEMORY:
+ return ENOMEM;
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
+ return KRB5_EAI_NODATA;
++#endif
+ #endif
+ case EAI_NONAME:
+ return KRB5_EAI_NONAME;
diff --git a/security/krb5-16/files/patch-lib::krb5::os::locate_kdc.c b/security/krb5-16/files/patch-lib::krb5::os::locate_kdc.c
new file mode 100644
index 000000000000..5cfbbe3553de
--- /dev/null
+++ b/security/krb5-16/files/patch-lib::krb5::os::locate_kdc.c
@@ -0,0 +1,13 @@
+--- lib/krb5/os/locate_kdc.c.orig Mon Jun 9 14:27:56 2003
++++ lib/krb5/os/locate_kdc.c Sun Jan 25 13:28:01 2004
+@@ -185,8 +185,10 @@
+ #ifdef EAI_ADDRFAMILY
+ case EAI_ADDRFAMILY:
+ #endif
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
++#endif
+ #endif
+ case EAI_NONAME:
+ /* Name not known or no address data, but no error. Do
diff --git a/security/krb5-17/Makefile b/security/krb5-17/Makefile
index 09194e6cc737..6c19574c3837 100644
--- a/security/krb5-17/Makefile
+++ b/security/krb5-17/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-17/files/patch-lib::krb5::os::hst_realm.c b/security/krb5-17/files/patch-lib::krb5::os::hst_realm.c
new file mode 100644
index 000000000000..d3caed59fd30
--- /dev/null
+++ b/security/krb5-17/files/patch-lib::krb5::os::hst_realm.c
@@ -0,0 +1,14 @@
+--- lib/krb5/os/hst_realm.c.orig Tue Oct 15 15:51:50 2002
++++ lib/krb5/os/hst_realm.c Sat Jan 24 20:11:05 2004
+@@ -438,9 +438,11 @@
+ return EAFNOSUPPORT;
+ case EAI_MEMORY:
+ return ENOMEM;
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
+ return KRB5_EAI_NODATA;
++#endif
+ #endif
+ case EAI_NONAME:
+ return KRB5_EAI_NONAME;
diff --git a/security/krb5-17/files/patch-lib::krb5::os::locate_kdc.c b/security/krb5-17/files/patch-lib::krb5::os::locate_kdc.c
new file mode 100644
index 000000000000..5cfbbe3553de
--- /dev/null
+++ b/security/krb5-17/files/patch-lib::krb5::os::locate_kdc.c
@@ -0,0 +1,13 @@
+--- lib/krb5/os/locate_kdc.c.orig Mon Jun 9 14:27:56 2003
++++ lib/krb5/os/locate_kdc.c Sun Jan 25 13:28:01 2004
+@@ -185,8 +185,10 @@
+ #ifdef EAI_ADDRFAMILY
+ case EAI_ADDRFAMILY:
+ #endif
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
++#endif
+ #endif
+ case EAI_NONAME:
+ /* Name not known or no address data, but no error. Do
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 09194e6cc737..6c19574c3837 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5-appl/files/patch-lib::krb5::os::hst_realm.c b/security/krb5-appl/files/patch-lib::krb5::os::hst_realm.c
new file mode 100644
index 000000000000..d3caed59fd30
--- /dev/null
+++ b/security/krb5-appl/files/patch-lib::krb5::os::hst_realm.c
@@ -0,0 +1,14 @@
+--- lib/krb5/os/hst_realm.c.orig Tue Oct 15 15:51:50 2002
++++ lib/krb5/os/hst_realm.c Sat Jan 24 20:11:05 2004
+@@ -438,9 +438,11 @@
+ return EAFNOSUPPORT;
+ case EAI_MEMORY:
+ return ENOMEM;
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
+ return KRB5_EAI_NODATA;
++#endif
+ #endif
+ case EAI_NONAME:
+ return KRB5_EAI_NONAME;
diff --git a/security/krb5-appl/files/patch-lib::krb5::os::locate_kdc.c b/security/krb5-appl/files/patch-lib::krb5::os::locate_kdc.c
new file mode 100644
index 000000000000..5cfbbe3553de
--- /dev/null
+++ b/security/krb5-appl/files/patch-lib::krb5::os::locate_kdc.c
@@ -0,0 +1,13 @@
+--- lib/krb5/os/locate_kdc.c.orig Mon Jun 9 14:27:56 2003
++++ lib/krb5/os/locate_kdc.c Sun Jan 25 13:28:01 2004
+@@ -185,8 +185,10 @@
+ #ifdef EAI_ADDRFAMILY
+ case EAI_ADDRFAMILY:
+ #endif
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
++#endif
+ #endif
+ case EAI_NONAME:
+ /* Name not known or no address data, but no error. Do
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 09194e6cc737..6c19574c3837 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
# USE_TARBALL tells the port that the user has fetched the source
# directly from MIT or crypto-publish.org (CRYTPO-PUBLISH).
diff --git a/security/krb5/files/patch-lib::krb5::os::hst_realm.c b/security/krb5/files/patch-lib::krb5::os::hst_realm.c
new file mode 100644
index 000000000000..d3caed59fd30
--- /dev/null
+++ b/security/krb5/files/patch-lib::krb5::os::hst_realm.c
@@ -0,0 +1,14 @@
+--- lib/krb5/os/hst_realm.c.orig Tue Oct 15 15:51:50 2002
++++ lib/krb5/os/hst_realm.c Sat Jan 24 20:11:05 2004
+@@ -438,9 +438,11 @@
+ return EAFNOSUPPORT;
+ case EAI_MEMORY:
+ return ENOMEM;
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
+ return KRB5_EAI_NODATA;
++#endif
+ #endif
+ case EAI_NONAME:
+ return KRB5_EAI_NONAME;
diff --git a/security/krb5/files/patch-lib::krb5::os::locate_kdc.c b/security/krb5/files/patch-lib::krb5::os::locate_kdc.c
new file mode 100644
index 000000000000..5cfbbe3553de
--- /dev/null
+++ b/security/krb5/files/patch-lib::krb5::os::locate_kdc.c
@@ -0,0 +1,13 @@
+--- lib/krb5/os/locate_kdc.c.orig Mon Jun 9 14:27:56 2003
++++ lib/krb5/os/locate_kdc.c Sun Jan 25 13:28:01 2004
+@@ -185,8 +185,10 @@
+ #ifdef EAI_ADDRFAMILY
+ case EAI_ADDRFAMILY:
+ #endif
++#ifdef EAI_NODATA
+ #if EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
++#endif
+ #endif
+ case EAI_NONAME:
+ /* Name not known or no address data, but no error. Do