aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
committerKris Kennaway <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
commitefd3830f38faa0eca31dabfbd2ce708b6c45263a (patch)
tree21a9b604b8e8633c1a971091f247a7384581af5e /shells
parentee35d188a209aa8ccacf3f483fb7c0bd1d5e84c2 (diff)
downloadfreebsd-ports-efd3830f38faa0eca31dabfbd2ce708b6c45263a.tar.gz
freebsd-ports-efd3830f38faa0eca31dabfbd2ce708b6c45263a.tar.zst
freebsd-ports-efd3830f38faa0eca31dabfbd2ce708b6c45263a.zip
BROKEN on 5.x: does not compile
Notes
Notes: svn path=/head/; revision=91379
Diffstat (limited to 'shells')
-rw-r--r--shells/bash1/Makefile8
-rw-r--r--shells/wapsh/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/shells/bash1/Makefile b/shells/bash1/Makefile
index 649b5b911f4d..e44b06377eaa 100644
--- a/shells/bash1/Makefile
+++ b/shells/bash1/Makefile
@@ -22,7 +22,13 @@ NOMANCOMPRESS= yes
MAN1= bash.1 bash_builtins.1
INFO= bash
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@install-info ${PREFIX}/info/bash.info ${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index 3da577109096..c3c1d656e5bb 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -42,6 +42,12 @@ HTDOCS= command.php command_html.inc command_wml.inc \
login_html.php login_wml.php scroll_wml.php \
shortcuts_wml.php
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > ${WRKDIR}/foo && \
${MV} ${WRKDIR}/foo ${WRKSRC}/htshd/htshd.c
@@ -96,4 +102,4 @@ post-install:
fi
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>