aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/beadm
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-07-09 00:47:22 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2017-07-09 00:47:22 +0800
commit4453c8dc2d8f146ec9e2ceff1d010bd5d5a8941f (patch)
tree3c8fb0acc8d8d936094d62c5111d3977966b3744 /sysutils/beadm
parent9f0ba3dd3dd2d80679abcb2ba1b57a14fefb1cad (diff)
downloadfreebsd-ports-4453c8dc2d8f146ec9e2ceff1d010bd5d5a8941f.tar.gz
freebsd-ports-4453c8dc2d8f146ec9e2ceff1d010bd5d5a8941f.tar.zst
freebsd-ports-4453c8dc2d8f146ec9e2ceff1d010bd5d5a8941f.zip
Unbreak 'beadm list'.
This basically reverts to 1.2.6 minus a 2>/dev/null change remaining. PR: 219256 Reported by: dim
Notes
Notes: svn path=/head/; revision=445340
Diffstat (limited to 'sysutils/beadm')
-rw-r--r--sysutils/beadm/Makefile2
-rw-r--r--sysutils/beadm/files/patch-beadm15
2 files changed, 12 insertions, 5 deletions
diff --git a/sysutils/beadm/Makefile b/sysutils/beadm/Makefile
index d1adaebf56a1..cb62c3004129 100644
--- a/sysutils/beadm/Makefile
+++ b/sysutils/beadm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= beadm
PORTVERSION= 1.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= GH \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/sysutils/beadm/files/patch-beadm b/sysutils/beadm/files/patch-beadm
index f75f72f259d5..70a7940c4c86 100644
--- a/sysutils/beadm/files/patch-beadm
+++ b/sysutils/beadm/files/patch-beadm
@@ -1,7 +1,5 @@
-diff --git beadm beadm
-index 6a0e397..f817e40 100755
---- beadm
-+++ beadm
+--- beadm.orig 2017-01-13 15:25:44.000000000 -0800
++++ beadm 2017-07-08 09:45:40.962588000 -0700
@@ -128,6 +128,24 @@ __be_new() { # 1=SOURCE 2=TARGET
unset NAME_NEW
unset NAME_SANITY
@@ -81,3 +79,12 @@ index 6a0e397..f817e40 100755
# clone properties of source boot environment
zfs list -H -o name -r ${SOURCE} \
| grep -v '@' \
+@@ -303,7 +351,7 @@ case ${1} in
+ while(CMD_ZFS_LIST BENAME_BEGINS_WITH | getline) {
+ if($1 != BENAME_BEGINS_WITH) {
+ FSNAME = $1
+- FSNAMES[length(FSNAME) + 1] = FSNAME
++ FSNAMES[length(FSNAMES) + 1] = FSNAME
+ USED = __normalize($2)
+ USEDBYDATASET = __normalize($3)
+ USEDBYSNAPSHOTS = __normalize($4)