aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/wmmon
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1998-12-11 23:22:46 +0800
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1998-12-11 23:22:46 +0800
commit2b5e20df2ddecc55c0ad53f9bd3768540486c2e9 (patch)
tree951f1a64990e77e2f3c8b04e79b802fe1fb1cd37 /sysutils/wmmon
parent1fc543b1a761fe3ff268a85c07ed82e3ac9b878e (diff)
downloadfreebsd-ports-2b5e20df2ddecc55c0ad53f9bd3768540486c2e9.tar.gz
freebsd-ports-2b5e20df2ddecc55c0ad53f9bd3768540486c2e9.tar.zst
freebsd-ports-2b5e20df2ddecc55c0ad53f9bd3768540486c2e9.zip
PR: ports/8874
Submitted by: kkennawa@physics.adelaide.edu.au WMMon monitors the realtime CPU load as well the average system load and gives you some nice additional features too...
Notes
Notes: svn path=/head/; revision=15279
Diffstat (limited to 'sysutils/wmmon')
-rw-r--r--sysutils/wmmon/Makefile40
-rw-r--r--sysutils/wmmon/distinfo2
-rw-r--r--sysutils/wmmon/files/patch-aa13
-rw-r--r--sysutils/wmmon/pkg-comment1
-rw-r--r--sysutils/wmmon/pkg-descr17
-rw-r--r--sysutils/wmmon/pkg-plist3
6 files changed, 76 insertions, 0 deletions
diff --git a/sysutils/wmmon/Makefile b/sysutils/wmmon/Makefile
new file mode 100644
index 000000000000..2dec396b0188
--- /dev/null
+++ b/sysutils/wmmon/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: wmmon
+# Version required: 1.0b2
+# Date created: 27 November 1998
+# Whom: Kris Kennaway <kkennawa@physics.adelaide.edu.au>
+#
+# $Id$
+#
+
+DISTNAME= wmmon-1.0b2
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.mezaway.org/pub/
+DISTFILES= wmmon-1.0b2.tar.gz wmmon-1.0b2-bsd.tar.gz
+
+MAINTAINER= kkennawa@physics.adelaide.edu.au
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/wmmon.app/wmmon
+
+pre-patch:
+ cd ${WRKDIR}/wmmon.app && ${PATCH} -p < ${WRKDIR}/wmmon-freebsd.patch
+
+post-extract:
+ ${CP} ${WRKDIR}/wmmon/Makefile.FreeBSD ${WRKSRC}/Makefile
+
+pre-clean:
+ ${RM} ${WRKDIR}/wmmon-freebsd.patch
+ ${RM} -rf ${WRKDIR}/wmmon
+
+post-install:
+ strip ${PREFIX}/bin/wmmon
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/wmmon
+ ${INSTALL_MAN} ${WRKSRC}/../HINTS ${PREFIX}/share/doc/wmmon
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/wmmon/distinfo b/sysutils/wmmon/distinfo
new file mode 100644
index 000000000000..0c9f4ec6420a
--- /dev/null
+++ b/sysutils/wmmon/distinfo
@@ -0,0 +1,2 @@
+MD5 (wmmon-1.0b2.tar.gz) = 1b8c780b8c24a6958c69330fef4171df
+MD5 (wmmon-1.0b2-bsd.tar.gz) = 8da39c1a9ec24c8cf0857c7fa3f8582c
diff --git a/sysutils/wmmon/files/patch-aa b/sysutils/wmmon/files/patch-aa
new file mode 100644
index 000000000000..edfa6ce40531
--- /dev/null
+++ b/sysutils/wmmon/files/patch-aa
@@ -0,0 +1,13 @@
+*** Makefile2 Mon Nov 30 21:31:27 1998
+--- Makefile Mon Nov 30 21:34:18 1998
+***************
+*** 21,24 ****
+ rm -f $(PROG)
+
+ install::
+! install -c -g kmem -m 4755 -o root $(PROG) /usr/X11R6/bin
+--- 21,24 ----
+ rm -f $(PROG)
+
+ install::
+! install -c -g kmem -m 4755 -o root $(PROG) $(PREFIX)/bin
diff --git a/sysutils/wmmon/pkg-comment b/sysutils/wmmon/pkg-comment
new file mode 100644
index 000000000000..b482f69948d8
--- /dev/null
+++ b/sysutils/wmmon/pkg-comment
@@ -0,0 +1 @@
+WindowMaker dockable system load/performance monitor.
diff --git a/sysutils/wmmon/pkg-descr b/sysutils/wmmon/pkg-descr
new file mode 100644
index 000000000000..9d11bcd0606f
--- /dev/null
+++ b/sysutils/wmmon/pkg-descr
@@ -0,0 +1,17 @@
+WMMon monitors the realtime CPU load as well the average system load and gives
+you some nice additional features too...
+
+WMMon currently provides:
+
+ * Realtime CPU 'stress' meter;
+ * Average systemload, like xload & wmavgload;
+ * Average systemload graphic is autoscaling;
+ * Realtime Disk I/O 'stress' meter;
+ * Average Disk I/O load grapic (autoscaling);
+ * Realtime total Mem & Swap usage meters;
+ * System uptime display;
+ * Realtime cycling through all monitor modes;
+ * Can lauch 3 user definable commands through ~/.wmmonrc;
+ * Can be started multiple times;
+ * Commandline options for help (-h), version (-v),
+ start mode (-i & -s) and display (-d);
diff --git a/sysutils/wmmon/pkg-plist b/sysutils/wmmon/pkg-plist
new file mode 100644
index 000000000000..576f7f90c9a4
--- /dev/null
+++ b/sysutils/wmmon/pkg-plist
@@ -0,0 +1,3 @@
+bin/wmmon
+share/doc/wmmon/HINTS
+@dirrm share/doc/wmmon