aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-27 10:47:27 +0800
committerPatrick Li <pat@FreeBSD.org>2002-01-27 10:47:27 +0800
commit20309e3ab87a1d0e131279bbaf6d8f8ee7d01a10 (patch)
tree100e13de7f6a5909236bd7b94a2eb7a31f0362d0 /sysutils
parent64758c9a38864ed17b2e56b8ef615fa6a6be45e5 (diff)
downloadfreebsd-ports-20309e3ab87a1d0e131279bbaf6d8f8ee7d01a10.tar.gz
freebsd-ports-20309e3ab87a1d0e131279bbaf6d8f8ee7d01a10.tar.zst
freebsd-ports-20309e3ab87a1d0e131279bbaf6d8f8ee7d01a10.zip
Update to 2.1.0
PR: 34221 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=53813
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fcron/Makefile9
-rw-r--r--sysutils/fcron/distinfo2
-rw-r--r--sysutils/fcron/files/patch-Makefile.in21
-rw-r--r--sysutils/fcron/pkg-message5
-rw-r--r--sysutils/fcron/pkg-plist13
5 files changed, 36 insertions, 14 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 63169766d0ef..bd0130392cc5 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= fcron
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://fcron.free.fr/
@@ -34,10 +34,17 @@ MAN5= fcrontab.5 fcron.conf.5
MAN8= fcron.8
post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/FAQ ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/files/fcron.pam ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/files/fcrontab.pam ${DOCSDIR}
+.endif
.for i in allow deny conf
.if !exists(${PREFIX}/etc/fcron.$i)
@${CP} -p ${PREFIX}/etc/fcron.$i.dist ${PREFIX}/etc/fcron.$i
.endif
.endfor
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/fcron/distinfo b/sysutils/fcron/distinfo
index 9661295ff083..4bf53ab9da73 100644
--- a/sysutils/fcron/distinfo
+++ b/sysutils/fcron/distinfo
@@ -1 +1 @@
-MD5 (fcron-2.0.0.src.tar.gz) = b20c6bc5d9435a790e5500ecb7990df8
+MD5 (fcron-2.1.0.src.tar.gz) = 054a21772e06ea9b37243c34d38fd9fb
diff --git a/sysutils/fcron/files/patch-Makefile.in b/sysutils/fcron/files/patch-Makefile.in
index c14b74ebcc86..0c31473ce67a 100644
--- a/sysutils/fcron/files/patch-Makefile.in
+++ b/sysutils/fcron/files/patch-Makefile.in
@@ -1,14 +1,29 @@
---- Makefile.in.orig Tue Jul 10 23:59:49 2001
-+++ Makefile.in Sat Sep 22 00:35:39 2001
-@@ -108,8 +108,9 @@
+--- Makefile.in.org Wed Jan 23 21:49:55 2002
++++ Makefile.in Wed Jan 23 21:50:52 2002
+@@ -102,23 +102,20 @@
+ if test ! -d $(DESTMAN)/man3; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man3 ; fi
+ if test ! -d $(DESTMAN)/man5; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man5 ; fi
+ if test ! -d $(DESTMAN)/man8; then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTMAN)/man8 ; fi
+- if test ! -d $(DESTDOC)/fcron-$(VERSION); then $(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 755 -d $(DESTDOC)/fcron-$(VERSION) ; fi
+ # create the spool dir (and change its mode if it already exists)
+ $(INSTALL) -g $(GROUPNAME) -o $(USERNAME) -m 770 -d $(FCRONTABS)
+
$(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 110 -s fcron $(DESTSBIN)
$(INSTALL) -g $(GROUPNAME) -o $(USERNAME) -m 6111 -s fcrontab $(DESTBIN)
$(INSTALL) -g $(ROOTGROUP) -o $(ROOTNAME) -m 6111 -s fcronsighup $(DESTBIN)
- test -f $(ETC)/fcron.allow || test -f $(ETC)/fcron.deny || $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.allow $(SRCDIR)/files/fcron.deny $(ETC)
- test -f $(ETC)/fcron.conf || $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.conf $(ETC)
+- test "${USEPAM}" = "0" || $(SRCDIR)/script/install-pam-conf $(SRCDIR) $(ETC) $(ROOTNAME) $(ROOTGROUP) "$(INSTALL)"
+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.allow $(ETC)/fcron.allow.dist
+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.deny $(ETC)/fcron.deny.dist
+ $(INSTALL) -m 640 -o $(ROOTNAME) -g $(GROUPNAME) $(SRCDIR)/files/fcron.conf $(ETC)/fcron.conf.dist
$(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcron.8 $(DESTMAN)/man8
$(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcrontab.1 $(DESTMAN)/man1
$(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcrontab.5 $(DESTMAN)/man5
+ $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/fcron.conf.5 $(DESTMAN)/man5
+ $(INSTALL) -m 644 -o $(ROOTNAME) $(SRCDIR)/doc/bitstring.3 $(DESTMAN)/man3
+- $(INSTALL) -m 644 -o $(ROOTNAME) doc/README doc/LICENSE doc/CHANGES doc/*.html \
+- $(DESTDOC)/fcron-$(VERSION)/
+
+ # in order to get correct rights when upgrading :
+ find $(FCRONTABS) -type f \( -name "*.orig" -a ! -name "root.orig" \) -exec chown $(USERNAME):$(GROUPNAME) {} \; -exec chmod 640 {} \;
diff --git a/sysutils/fcron/pkg-message b/sysutils/fcron/pkg-message
new file mode 100644
index 000000000000..27df0b2f9ab2
--- /dev/null
+++ b/sysutils/fcron/pkg-message
@@ -0,0 +1,5 @@
+
+This new version of fcron uses PAM support for authentication.
+Please refer to the fcron.pam and fcrontab.pam files in the
+documentation directory for configuring PAM.
+
diff --git a/sysutils/fcron/pkg-plist b/sysutils/fcron/pkg-plist
index 2ed191af7b53..890e3eaa4892 100644
--- a/sysutils/fcron/pkg-plist
+++ b/sysutils/fcron/pkg-plist
@@ -11,12 +11,7 @@ etc/fcron.deny.dist
etc/fcron.conf.dist
@exec [ -f %B/fcron.conf ] || cp %B/%f %B/fcron.conf
etc/rc.d/fcron.sh
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/CHANGES
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/LICENSE
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/README
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/fcron.8.html
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/fcrontab.1.html
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/fcrontab.5.html
-%%PORTDOCS%%share/doc/fcron/fcron-%%PORTVERSION%%/fcron.conf.5.html
-%%PORTDOCS%%@dirrm share/doc/fcron/fcron-%%PORTVERSION%%
-%%PORTDOCS%%@dirrm share/doc/fcron
+%%PORTDOCS%%share/doc/fcron/FAQ
+%%PORTDOCS%%share/doc/fcron/fcron.pam
+%%PORTDOCS%%share/doc/fcron/fcrontab.pam
+%%PORTDOCS%%@unexec rmdir %D/share/doc/fcron 2>/dev/null || true