aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-23 15:55:56 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-23 15:55:56 +0800
commit42f72e635a771334333d3e5d6d07b3111c1eae0a (patch)
tree26a18bbdc900d0fcb871de300bcfb304662c7497 /textproc
parent6fc836634345a96793a6db3932d7087417d7d3cb (diff)
downloadfreebsd-ports-42f72e635a771334333d3e5d6d07b3111c1eae0a.tar.gz
freebsd-ports-42f72e635a771334333d3e5d6d07b3111c1eae0a.tar.zst
freebsd-ports-42f72e635a771334333d3e5d6d07b3111c1eae0a.zip
Add ruby-qt2xml, Qt2 xml extension for Ruby.
Notes
Notes: svn path=/head/; revision=37474
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ruby-qt2xml/Makefile48
-rw-r--r--textproc/ruby-qt2xml/pkg-comment1
-rw-r--r--textproc/ruby-qt2xml/pkg-descr4
-rw-r--r--textproc/ruby-qt2xml/pkg-plist17
5 files changed, 71 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index cff7e8cd3322..cff2d086d39f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -116,6 +116,7 @@
SUBDIR += rand
SUBDIR += rman
SUBDIR += ruby-html-parser
+ SUBDIR += ruby-qt2xml
SUBDIR += ruby-rdtool
SUBDIR += ruby-xmlparser
SUBDIR += rxp
diff --git a/textproc/ruby-qt2xml/Makefile b/textproc/ruby-qt2xml/Makefile
new file mode 100644
index 000000000000..9d6431223225
--- /dev/null
+++ b/textproc/ruby-qt2xml/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: Ruby-qt2xml
+# Date created: 23 Jan 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt2xml
+PORTVERSION= 0.11
+CATEGORIES= textproc x11-toolkits ruby
+MASTER_SITES= http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-qt2-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
+
+RUBY_QT2_PORTDIR= ${PORTSDIR}/x11-toolkits/ruby-qt2
+
+MD5_FILE= ${RUBY_QT2_PORTDIR}/distinfo
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/qt2/modules/xml
+CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
+ --with-qt2-lib=${X11BASE}/lib \
+ --with-qt2=qt2 \
+ --with-x11-dir=${X11BASE}
+MAKE_ARGS= LOCAL_LIBS=-lgcc
+INSTALL_TARGET= site-install
+
+post-extract:
+ cd ${WRKSRC}/examples/domexample && \
+ ${RM} domtest1.cc domtest1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/qt2xml
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/qt2xml/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-qt2xml/pkg-comment b/textproc/ruby-qt2xml/pkg-comment
new file mode 100644
index 000000000000..22fed3cf922c
--- /dev/null
+++ b/textproc/ruby-qt2xml/pkg-comment
@@ -0,0 +1 @@
+Qt2 xml extension for Ruby
diff --git a/textproc/ruby-qt2xml/pkg-descr b/textproc/ruby-qt2xml/pkg-descr
new file mode 100644
index 000000000000..f1337a16d9f0
--- /dev/null
+++ b/textproc/ruby-qt2xml/pkg-descr
@@ -0,0 +1,4 @@
+This is a Qt2 xml extension for Ruby.
+
+Author: Nobuyuki Horie <horie@smail.u-shizuoka-ken.ac.jp>
+WWW: http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/index.html
diff --git a/textproc/ruby-qt2xml/pkg-plist b/textproc/ruby-qt2xml/pkg-plist
new file mode 100644
index 000000000000..79cdcd286c4f
--- /dev/null
+++ b/textproc/ruby-qt2xml/pkg-plist
@@ -0,0 +1,17 @@
+%%RUBY_SITEARCHLIBDIR%%/qt2xml.so
+%%RUBY_EXAMPLESDIR%%/qt2xml/domexample/quotes.xml
+%%RUBY_EXAMPLESDIR%%/qt2xml/domexample/domtest1.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sax.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sample.xml
+%%RUBY_EXAMPLESDIR%%/qt2xml/saxsample/sample1.ui
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/README.orig
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/quotes.xml
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/richtext.h.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/richtext.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/quoteparser.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/xmlquotes.rb
+%%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes/marble.png
+@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/domexample
+@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/saxsample
+@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml/xmlquotes
+@dirrm %%RUBY_EXAMPLESDIR%%/qt2xml