aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-04 07:23:26 +0800
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-04 07:23:26 +0800
commit7a312e7e09357213eaa58e765477666171ea2963 (patch)
treed5cdddccc8fb75e3d15b46d08c83cb6a76a8110f /textproc
parent4cfd446861e75c9face438c4f558a6580297edee (diff)
downloadfreebsd-ports-7a312e7e09357213eaa58e765477666171ea2963.tar.gz
freebsd-ports-7a312e7e09357213eaa58e765477666171ea2963.tar.zst
freebsd-ports-7a312e7e09357213eaa58e765477666171ea2963.zip
New Port: Customize TEI DTDs
Generate customized TEI-DTDs PR: ports/38341 Submitted by: Henrik Motakef <henrik.motakef@web.de>
Notes
Notes: svn path=/head/; revision=72473
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/maketeidtd/Makefile43
-rw-r--r--textproc/maketeidtd/distinfo1
-rw-r--r--textproc/maketeidtd/pkg-comment1
-rw-r--r--textproc/maketeidtd/pkg-descr8
-rw-r--r--textproc/maketeidtd/pkg-plist15
6 files changed, 69 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 32a56a53bd46..76f8abf75e91 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -127,6 +127,7 @@
SUBDIR += linuxdoc
SUBDIR += ltxml
SUBDIR += makepatch
+ SUBDIR += maketeidtd
SUBDIR += man2html
SUBDIR += manued.el
SUBDIR += mgdiff
diff --git a/textproc/maketeidtd/Makefile b/textproc/maketeidtd/Makefile
new file mode 100644
index 000000000000..4774446b8d4a
--- /dev/null
+++ b/textproc/maketeidtd/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: maketeidtd
+# Date created: 18 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= maketeidtd
+PORTVERSION= 20020414 # Cannot find a "real" version number
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Software/maketeidtd/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= henrik.motakef@web.de
+
+RUN_DEPENDS= carthage:${PORTSDIR}/textproc/carthage \
+ ${LOCALBASE}/share/sgml/tei/p4/tei2.dtd:${PORTSDIR}/textproc/tei-p4
+
+USE_PERL5= yes
+USE_ZIP= yes
+NO_BUILD= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/maketeidtd ${WRKSRC}/maketeidtd.tmp
+ @${SED} -e 's;#!/usr/bin/perl;#!${PERL};' \
+ -e 's;../../P4X/DTD;${PREFIX}/share/sgml/tei/p4;' \
+ ${WRKSRC}/maketeidtd.tmp > ${WRKSRC}/maketeidtd
+ @${RM} ${WRKSRC}/maketeidtd.tmp
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/maketeidtd ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/maketeidtd
+ @${MKDIR} ${PREFIX}/share/examples/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.html ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.xml ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/index.xsl ${PREFIX}/share/doc/maketeidtd
+ @${INSTALL_MAN} ${WRKSRC}/examples/* ${PREFIX}/share/examples/maketeidtd
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/maketeidtd/distinfo b/textproc/maketeidtd/distinfo
new file mode 100644
index 000000000000..7e5213f197c8
--- /dev/null
+++ b/textproc/maketeidtd/distinfo
@@ -0,0 +1 @@
+MD5 (maketeidtd.zip) = 858ef44aad7166f41ca247b7cdcc40e9
diff --git a/textproc/maketeidtd/pkg-comment b/textproc/maketeidtd/pkg-comment
new file mode 100644
index 000000000000..ac441eb42cf2
--- /dev/null
+++ b/textproc/maketeidtd/pkg-comment
@@ -0,0 +1 @@
+Generate customized TEI-DTDs
diff --git a/textproc/maketeidtd/pkg-descr b/textproc/maketeidtd/pkg-descr
new file mode 100644
index 000000000000..3cfa4f0aa449
--- /dev/null
+++ b/textproc/maketeidtd/pkg-descr
@@ -0,0 +1,8 @@
+A perl-script to generate customized TEI-DTDs by chosing element and entity
+sets or providing user-defined modifications. Can generate either SGML or XML
+DTDs.
+
+WWW: http://www.tei-c.org/Software/maketeidtd/
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/textproc/maketeidtd/pkg-plist b/textproc/maketeidtd/pkg-plist
new file mode 100644
index 000000000000..063d34d61a1d
--- /dev/null
+++ b/textproc/maketeidtd/pkg-plist
@@ -0,0 +1,15 @@
+bin/maketeidtd
+%%PORTDOCS%%share/doc/maketeidtd/index.html
+%%PORTDOCS%%share/doc/maketeidtd/index.xml
+%%PORTDOCS%%share/doc/maketeidtd/index.xsl
+%%PORTDOCS%%share/examples/maketeidtd/equation.dtd
+%%PORTDOCS%%share/examples/maketeidtd/iso-lat1.ent
+%%PORTDOCS%%share/examples/maketeidtd/iso-lat2.ent
+%%PORTDOCS%%share/examples/maketeidtd/iso-num.ent
+%%PORTDOCS%%share/examples/maketeidtd/iso-pub.ent
+%%PORTDOCS%%share/examples/maketeidtd/tei-equation.dtd
+%%PORTDOCS%%share/examples/maketeidtd/tei-equation.ent
+%%PORTDOCS%%share/examples/maketeidtd/teilitex.dtd
+%%PORTDOCS%%share/examples/maketeidtd/teilitex.ent
+%%PORTDOCS%%@dirrm share/doc/maketeidtd
+%%PORTDOCS%%@dirrm share/examples/maketeidtd