aboutsummaryrefslogtreecommitdiffstats
path: root/vietnamese
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1996-12-06 20:33:53 +0800
committerDavid E. O'Brien <obrien@FreeBSD.org>1996-12-06 20:33:53 +0800
commite0dead1af63debacb7940557ec49473b910a43b5 (patch)
treefde0cf7867b0e90f78bbdf545567a865af7b77c3 /vietnamese
parentc23ec56433519341184b454e5620bd24d652f94b (diff)
downloadfreebsd-ports-e0dead1af63debacb7940557ec49473b910a43b5.tar.gz
freebsd-ports-e0dead1af63debacb7940557ec49473b910a43b5.tar.zst
freebsd-ports-e0dead1af63debacb7940557ec49473b910a43b5.zip
vnxterm is a xterm replacement with Vietnamese VIQR 1.1 (7-bit VIetnamese
Quoted Readable/Viet-Net) support. This version of cxterm is derived from the X11R5 xterm, and thus has simular capabilities.
Notes
Notes: svn path=/head/; revision=4834
Diffstat (limited to 'vietnamese')
-rw-r--r--vietnamese/vnterm/Makefile43
-rw-r--r--vietnamese/vnterm/distinfo1
-rw-r--r--vietnamese/vnterm/files/VNterm.sh.in72
-rw-r--r--vietnamese/vnterm/files/patch-0121
-rw-r--r--vietnamese/vnterm/files/patch-0226
-rw-r--r--vietnamese/vnterm/files/patch-0313
-rw-r--r--vietnamese/vnterm/files/patch-0411
-rw-r--r--vietnamese/vnterm/files/patch-0519
-rw-r--r--vietnamese/vnterm/files/patch-0652
-rw-r--r--vietnamese/vnterm/pkg-comment1
-rw-r--r--vietnamese/vnterm/pkg-descr13
-rw-r--r--vietnamese/vnterm/pkg-plist9
-rw-r--r--vietnamese/vnterm/scripts/pre-install14
13 files changed, 295 insertions, 0 deletions
diff --git a/vietnamese/vnterm/Makefile b/vietnamese/vnterm/Makefile
new file mode 100644
index 000000000000..644c5354c6d9
--- /dev/null
+++ b/vietnamese/vnterm/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# New ports collection makefile for: vnterm
+# Version required: 3.3
+# Date created: Sat July 20, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.1.1.1 1996/08/09 04:17:16 asami Exp $
+#
+
+DISTNAME= vnterm3.3
+PKGNAME= vn-vnterm-3.3
+CATEGORIES= vietnamese x11
+MASTER_SITES= ftp://ftp.media.mit.edu/pub/Vietnet/Viscii/Unix/ \
+ ftp://ftp.monash.edu.au/pub/vietnam/unix/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+USE_IMAKE= yes
+XMKMF= xmkmf
+CFLAGS+= -I../../include
+
+post-patch:
+ @/bin/ln ${WRKSRC}/XTerm.ad ${WRKSRC}/VNTerm.ad
+ @/bin/ln ${WRKSRC}/vnterm.1V ${WRKSRC}/vnterm.man
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/VNterm.sh ${PREFIX}/bin/VNterm
+ @${MKDIR} ${PREFIX}/lib/X11/fonts/vietnamese
+ @(cd ${WRKSRC}/../fonts/X ; \
+ ${INSTALL_DATA} fonts.dir *.pcf.Z \
+ ${PREFIX}/lib/X11/fonts/vietnamese ; \
+ )
+ /bin/false
+ need to put below line in pkg/INSTALL?
+ @(cd ${PREFIX}/lib/X11/fonts/vietnamese ; mkfontdir >/dev/null 2>&1)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/vnterm \
+ && chmod a+rx ${PREFIX}/share/doc/vnterm
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/vnterm
+.endif
+
+.include <bsd.port.mk>
diff --git a/vietnamese/vnterm/distinfo b/vietnamese/vnterm/distinfo
new file mode 100644
index 000000000000..5bb5831b6b55
--- /dev/null
+++ b/vietnamese/vnterm/distinfo
@@ -0,0 +1 @@
+MD5 (vnterm3.3.tar.Z) = 6eb2fccfad669c1eb839778c34b5d956
diff --git a/vietnamese/vnterm/files/VNterm.sh.in b/vietnamese/vnterm/files/VNterm.sh.in
new file mode 100644
index 000000000000..48d56e0a6f2e
--- /dev/null
+++ b/vietnamese/vnterm/files/VNterm.sh.in
@@ -0,0 +1,72 @@
+# ex:ts=4
+# Modified from CXterm.sh included with the cxterm Chinese lang xterm pkg
+
+# ENCODE_FONTS: automaticially search for a font from the list
+
+#Files: "vn-r14 vn10x20 vn9x15 vnlutRS18"
+VN_FONTS="vn-r14 vn10x20 viet vn-lucidasanstypewriter-18"
+
+if [ "$BINDIR" != "" ]; then
+ VNTERM="$BINDIR/vnterm"
+else
+ VNTERM=vnterm
+fi
+
+check_use_font ()
+{
+ for f in "$@" ; do
+ if [ "`xlsfonts $f 2>/dev/null`" = "$f" ]; then
+ echo $f
+ return 0
+ fi
+ done
+ xset fp+ "$XFONTDIR"
+ for f in "$@" ; do
+ if [ "`xlsfonts $f 2>/dev/null`" = "$f" ]; then
+ echo $f
+ return 0
+ fi
+ done
+ return 1
+}
+
+
+CF=""
+FH=0
+for i in "$@" ; do
+ if [ "$i" = "-fh" ]; then
+ FH=1; continue;
+ fi
+ if [ "$FH" -eq 1 ]; then
+ CF=`check_use_font $i`
+ if [ "$CF" = "" ]; then
+ echo "Specified font doesn't exist in the X Window system."
+ exit 1
+ fi
+ break
+ fi
+ FH=0
+done
+
+
+if [ "$CF" = "" ]; then
+ if [ "$NAME" = "cxterm" ]; then
+ CF=`check_use_font $GB_FONTS`
+ if [ "$CF" = "" ]; then
+ echo "Cannot identify a Vietnamese font in the X Window system."
+ exit 1
+ fi
+ FH_OPT="-fh $CF"
+ elif [ "$NAME" = "cxtermb5" ]; then
+ CF=`check_use_font $BIG5_FONTS`
+ if [ "$CF" = "" ]; then
+ echo "Cannot identify a Vietnamese font in the X Window system."
+ exit 1
+ fi
+ FH_OPT="-fh $CF"
+ fi
+fi
+
+XENVIRONMENT=$VNTERM_AD
+export XENVIRONMENT
+exec $VNTERM $FH_OPT $*
diff --git a/vietnamese/vnterm/files/patch-01 b/vietnamese/vnterm/files/patch-01
new file mode 100644
index 000000000000..2d21ae8a23fe
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-01
@@ -0,0 +1,21 @@
+--- misc.c.orig Fri Jul 16 10:17:56 1993
++++ misc.c Sun Nov 24 18:29:09 1996
+@@ -34,6 +34,7 @@
+ #include <ctype.h>
+ #include <pwd.h>
+ #include <errno.h>
++#include <sys/param.h>
+
+ #include <X11/Xatom.h>
+ #include <X11/cursorfont.h>
+@@ -776,8 +777,10 @@
+ char *SysErrorMsg (n)
+ int n;
+ {
++#if !((defined(BSD) && (BSD >= 199103)))
+ extern char *sys_errlist[];
+ extern int sys_nerr;
++#endif
+
+ return ((n >= 0 && n < sys_nerr) ? sys_errlist[n] : "unknown error");
+ }
diff --git a/vietnamese/vnterm/files/patch-02 b/vietnamese/vnterm/files/patch-02
new file mode 100644
index 000000000000..74ea68c9bcc2
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-02
@@ -0,0 +1,26 @@
+--- ../lib/Makefile.orig Tue Aug 31 15:40:06 1993
++++ ../lib/Makefile Sun Nov 24 19:59:14 1996
+@@ -4,7 +4,7 @@
+ LIBDIRS = viqr vntype
+ LIBS = libviqr.a libvntype.a
+ #FLAGS = -DNO_ANSI_C
+-MFLAGS = -r
++#MFLAGS = -r
+
+ all:
+ @$(MAKE) MSG="Working on" TARGET=all forloop
+@@ -13,12 +13,13 @@
+ @$(MAKE) MSG="Working on" TARGET=clean forloop
+
+ forloop:
++ @echo "CFLAGS are $(CFLAGS)"
+ @for dir in $(LIBDIRS) ; do \
+ $(ECHO) "Working on" $$dir " {" ; \
+ cd $$dir ; \
+ PATH=".:$(PATH)" ; \
+ export PATH ; \
+- make $(MFLAGS) -e TAB="$(TAB)$(TAB)" $(TARGET) ; \
++ make $(MFLAGS) TAB="$(TAB)$(TAB)" $(TARGET) ; \
+ cd .. ; \
+ $(ECHO) "Done with" $$dir " }";\
+ $(ECHO) "" ;\
diff --git a/vietnamese/vnterm/files/patch-03 b/vietnamese/vnterm/files/patch-03
new file mode 100644
index 000000000000..a051d983070c
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-03
@@ -0,0 +1,13 @@
+--- ../lib/viqr/Makefile.orig Thu Jul 15 18:19:16 1993
++++ ../lib/viqr/Makefile Tue Dec 3 20:58:43 1996
+@@ -11,7 +11,9 @@
+ RANLIB= echo
+
+ SRCS = vncompos.c vnkeys.c vk_qrto8.c vk_8toqr.c
+-OBJS = vncompos.o vnkeys.o vk_qrto8.o vk_8toqr.o
++# vncompos.o must be last to be included in the library, otherwise
++# FreeBSD's ld can't resolve _vncompose and _vncompose_init -- DEO [Dec96]
++OBJS = vnkeys.o vk_qrto8.o vk_8toqr.o vncompos.o
+ LIB = $(VNLIBDIR)/libviqr.a
+
+ INC = -I$(VNINCDIR)
diff --git a/vietnamese/vnterm/files/patch-04 b/vietnamese/vnterm/files/patch-04
new file mode 100644
index 000000000000..ad0183bd856b
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-04
@@ -0,0 +1,11 @@
+--- ../lib/vntype/Makefile.orig Tue Aug 10 18:26:33 1993
++++ ../lib/vntype/Makefile Sun Nov 24 20:09:15 1996
+@@ -18,7 +18,7 @@
+ #FLAGS = -DNOANSI_C
+ CFLAGS = $(FLAGS) $(INC)
+ CC = cc
+-CPP = /lib/cpp
++CPP = cpp
+
+ .I.srt:
+ @echo -n "Generating $@ from $*.I..."
diff --git a/vietnamese/vnterm/files/patch-05 b/vietnamese/vnterm/files/patch-05
new file mode 100644
index 000000000000..eb677d71bf00
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-05
@@ -0,0 +1,19 @@
+--- ../fonts/X/Makefile.orig Tue Aug 31 15:42:26 1993
++++ ../fonts/X/Makefile Wed Dec 4 02:00:53 1996
+@@ -35,7 +35,7 @@
+ @echo $(TAB)We\'re going to do some font conversion.
+ @echo $(TAB)Depending on your system set-up, some of
+ @echo $(TAB)the conversion programs may not exist.
+- @echo $(TAB)Don't worry about this; it means that
++ @echo "$(TAB)Don't worry about this; it means that"
+ @echo $(TAB)your font format is one of the others.
+ @echo $(TAB)We try to cover PCF, SNF, and FB formats.
+ @echo $(TAB)You're out of luck if NONE of these work.
+@@ -71,6 +71,7 @@
+ else echo "I guess you don't." ;\
+ fi
+
++ -compress *.pcf
+ -mkfontdir >/dev/null 2>&1
+ @-chmod go+r fonts.*
+ @touch $(MADEFLAG)
diff --git a/vietnamese/vnterm/files/patch-06 b/vietnamese/vnterm/files/patch-06
new file mode 100644
index 000000000000..f0c2216a45e6
--- /dev/null
+++ b/vietnamese/vnterm/files/patch-06
@@ -0,0 +1,52 @@
+--- vnterm.1V.orig Tue May 26 16:57:45 1992
++++ vnterm.1V Wed Dec 4 00:52:33 1996
+@@ -1,7 +1,7 @@
+ .\" to view this file, use: nroff -man %M% | more
+ .\" %W% (TriChlor) %G% %U%
+ .\"
+-.TH vnterm.3 1V
++.TH vnterm 1V
+ .SH NAME
+ vnterm \- X-terminal with Vietnamese
+ .SH SYNTAX
+@@ -12,9 +12,9 @@
+ [\fIregular_xterm_options\fP]
+ .SH DESCRIPTION
+ .NXR "vnterm command"
+-Version 3.0 of
++Version 3.3 of
+ .PN vnterm
+-is an adaptation of the X11R4
++is an adaptation of the X11R5
+ .MS xterm 1X
+ command. This manual page describes only
+ those features specific to
+@@ -68,6 +68,7 @@
+ combination.
+ The corresponding X resources are:
+ .EX
++ vnterm*font: vn-r14
+ vnterm*vnFilterKeyboard: on
+ vnterm*vnFilterScreen: off
+ vnterm*vnEraseCharacter: 127
+@@ -203,12 +204,18 @@
+ menu of
+ .PN vnterm.
+ .SH AUTHOR
++4.4BSD porting by David O'Brien <obrien@cs.ucdavis.edu>
++.PP
++Adapted from X11R5's xterm by
++Tin Le <tin@saigon.com>
++.PP
+ Adapted from X11R4's xterm by
+ the TriChlor Group, TriChlor@haydn.Stanford.EDU.
+ .PP
+ Thanks to Tuan P. Do (tuan@compass-da.com) for illustrating
+ the need for the vnEraseCharacter specifier.
+ .SH "SEE ALSO"
+-The Viet-Std Standardization Specification (Viet-Std@Haydn.Stanford.EDU)
+-.br
++.PP
+ vietterm(1V), vnelvis(1V)
++.SH STANDARDS
++Viet-Std Standardization Specification (Viet-Std@Haydn.Stanford.EDU)
diff --git a/vietnamese/vnterm/pkg-comment b/vietnamese/vnterm/pkg-comment
new file mode 100644
index 000000000000..e336ccb7bda0
--- /dev/null
+++ b/vietnamese/vnterm/pkg-comment
@@ -0,0 +1 @@
+An xterm that speaks Vietnamese
diff --git a/vietnamese/vnterm/pkg-descr b/vietnamese/vnterm/pkg-descr
new file mode 100644
index 000000000000..43433f4d4c25
--- /dev/null
+++ b/vietnamese/vnterm/pkg-descr
@@ -0,0 +1,13 @@
+Tha^n cha`o ca'c ba.n,
+
+vnxterm is a xterm replacement with Vietnamese VIQR 1.1 (7-bit VIetnamese
+Quoted Readable/Viet-Net) support. This version of cxterm is derived from the
+X11R5 xterm, and thus has simular capabilities.
+
+Please see the README file in the share/doc/vnterm directory.
+
+ Note, if you are a new user, or not quite understand X resources or
+ X font paths, etc., simply use the command "VNterm".
+
+David O'Brien
+obrien@cs.ucdavis.edu
diff --git a/vietnamese/vnterm/pkg-plist b/vietnamese/vnterm/pkg-plist
new file mode 100644
index 000000000000..bd897edd2c46
--- /dev/null
+++ b/vietnamese/vnterm/pkg-plist
@@ -0,0 +1,9 @@
+bin/vnterm
+bin/VNterm
+man/man1/vnterm.1.gz
+lib/X11/app-defaults/VNTerm
+lib/X11/fonts/vietnamese/fonts.dir
+lib/X11/fonts/vietnamese/vn-r14.pcf.Z
+lib/X11/fonts/vietnamese/vn10x20.pcf.Z
+lib/X11/fonts/vietnamese/vn9x15.pcf.Z
+lib/X11/fonts/vietnamese/vnlutRS18.pcf.Z
diff --git a/vietnamese/vnterm/scripts/pre-install b/vietnamese/vnterm/scripts/pre-install
new file mode 100644
index 000000000000..0b1ef47d538a
--- /dev/null
+++ b/vietnamese/vnterm/scripts/pre-install
@@ -0,0 +1,14 @@
+#!/bin/sh -x
+
+# set up the resource file
+# nothing yet...
+
+# setup helper script
+echo "creating VNterm script for inexperienced users"
+VNTERM_SH=${WRKDIR}/VNterm.sh
+
+echo "#!/bin/sh" > $VNTERM_SH
+echo "" >> $VNTERM_SH
+echo "XFONTDIR=${PREFIX}/lib/X11/fonts/vietnamese" >> $VNTERM_SH
+echo "" >> $VNTERM_SH
+/bin/cat ${FILESDIR}/VNterm.sh.in >> $VNTERM_SH