aboutsummaryrefslogtreecommitdiffstats
path: root/www/barque
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2001-03-30 16:45:22 +0800
committerYukihiro Nakai <nakai@FreeBSD.org>2001-03-30 16:45:22 +0800
commitd0ce7b127529b21c6adc4d94b7317d079eb92024 (patch)
treecb81061e88ff40c67afa938da3a409c36faf99c0 /www/barque
parent2f0cf7d36ad05953b226f8e4aaf8a76089c1c201 (diff)
downloadfreebsd-ports-d0ce7b127529b21c6adc4d94b7317d079eb92024.tar.gz
freebsd-ports-d0ce7b127529b21c6adc4d94b7317d079eb92024.tar.zst
freebsd-ports-d0ce7b127529b21c6adc4d94b7317d079eb92024.zip
Initial import.
Barque is another WWW browser with gtkhtml.
Notes
Notes: svn path=/head/; revision=40573
Diffstat (limited to 'www/barque')
-rw-r--r--www/barque/Makefile40
-rw-r--r--www/barque/distinfo1
-rw-r--r--www/barque/files/patch-aa20
-rw-r--r--www/barque/files/patch-ab19
-rw-r--r--www/barque/pkg-comment1
-rw-r--r--www/barque/pkg-descr1
-rw-r--r--www/barque/pkg-plist8
7 files changed, 90 insertions, 0 deletions
diff --git a/www/barque/Makefile b/www/barque/Makefile
new file mode 100644
index 000000000000..9ac1e2af4194
--- /dev/null
+++ b/www/barque/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: barque
+# Date created: 28 March 2001
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= barque
+PORTVERSION= 0.1.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-0.1-2.tar.gz
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= gtkhtml.8:${PORTSDIR}/www/gtkhtml \
+ bonobo.2:${PORTSDIR}/devel/bonobo \
+ gconf-1.1:${PORTSDIR}/devel/gconf \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ ghttp.1:${PORTSDIR}/www/libghttp \
+ glade.4:${PORTSDIR}/devel/libglade
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1-2
+
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/www/barque/distinfo b/www/barque/distinfo
new file mode 100644
index 000000000000..43fd0ac7518d
--- /dev/null
+++ b/www/barque/distinfo
@@ -0,0 +1 @@
+MD5 (barque-0.1-2.tar.gz) = 2cfe1677744ad2ba9a38a16df3d3881c
diff --git a/www/barque/files/patch-aa b/www/barque/files/patch-aa
new file mode 100644
index 000000000000..8036a25b5d4d
--- /dev/null
+++ b/www/barque/files/patch-aa
@@ -0,0 +1,20 @@
+--- src/barque.c.orig Thu Mar 29 18:04:32 2001
++++ src/barque.c Thu Mar 29 18:04:43 2001
+@@ -263,7 +263,7 @@
+ {
+ int i;
+ char *filename = NULL, *rootnode = NULL;
+- GError* error = NULL;
++ GConfError* error = NULL;
+ GladeXML *xml;
+
+
+@@ -274,7 +274,7 @@
+ /* initialize gconf */
+ if (!gconf_init(argc, argv, &error)) {
+ g_assert(error != NULL);
+- g_warning("GConf init failed:\n %s", error->message);
++ g_warning("GConf init failed:\n %s", error->str);
+ g_error_free(error);
+ error = NULL;
+ return 1;
diff --git a/www/barque/files/patch-ab b/www/barque/files/patch-ab
new file mode 100644
index 000000000000..bdb31bd3cd17
--- /dev/null
+++ b/www/barque/files/patch-ab
@@ -0,0 +1,19 @@
+--- capplet/barque-capplet.c.orig Thu Mar 29 18:19:20 2001
++++ capplet/barque-capplet.c Thu Mar 29 18:19:32 2001
+@@ -91,14 +91,14 @@
+ int main(int argc, char *argv[]) {
+ GladeXML *xml;
+ GtkWidget *prefs;
+- static GError *error = NULL;
++ static GConfError *error = NULL;
+
+ if (gnome_capplet_init ("barque-capplet", VERSION, argc, argv, NULL, 0, NULL) < 0)
+ return 1;
+
+ if (!gconf_init(argc, argv, &error)) {
+ g_assert(error != NULL);
+- g_warning("GConf init failed:\n %s", error->message);
++ g_warning("GConf init failed:\n %s", error->str);
+ return 1;
+ }
+
diff --git a/www/barque/pkg-comment b/www/barque/pkg-comment
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/www/barque/pkg-comment
@@ -0,0 +1 @@
+
diff --git a/www/barque/pkg-descr b/www/barque/pkg-descr
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/www/barque/pkg-descr
@@ -0,0 +1 @@
+
diff --git a/www/barque/pkg-plist b/www/barque/pkg-plist
new file mode 100644
index 000000000000..eacce9f162da
--- /dev/null
+++ b/www/barque/pkg-plist
@@ -0,0 +1,8 @@
+bin/barque
+bin/barque-capplet
+share/gnome/apps/Settings/barque.desktop
+share/gnome/barque/authpopup.glade
+share/gnome/barque/barque-capplet.glade
+share/gnome/barque/barque.glade
+share/gnome/control-center/barque.desktop
+@dirrm share/gnome/barque