aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-17 03:03:10 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-17 03:03:10 +0800
commit1350c19569f6234f25899a111738851260b94038 (patch)
tree54c3d0dc8b7026e6f4e99056f3b2d04a00eae33d /www
parentb6e54fb48a02594edd704effd4026f5ff3b5620a (diff)
downloadfreebsd-ports-1350c19569f6234f25899a111738851260b94038.tar.gz
freebsd-ports-1350c19569f6234f25899a111738851260b94038.tar.zst
freebsd-ports-1350c19569f6234f25899a111738851260b94038.zip
Fix build on -CURRENT.
Notes
Notes: svn path=/head/; revision=61387
Diffstat (limited to 'www')
-rw-r--r--www/galeon/Makefile10
-rw-r--r--www/galeon/files/patch-src_mozilla_TOCProtocolHandler.cpp11
-rw-r--r--www/galeon2/Makefile10
-rw-r--r--www/galeon2/files/patch-src_mozilla_TOCProtocolHandler.cpp11
4 files changed, 40 insertions, 2 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 6eb3a1f4cda5..b59b68ed1067 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -41,6 +41,14 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+# Galeon does not build correctly in -CURRENT if -Werror is passed
+# to the compiler.
+CONFIGURE_ARGS+= --disable-werror
+.endif
+
post-extract:
.if !defined(WITH_FULL_MOZILLA)
@${ECHO_MSG}
@@ -69,4 +77,4 @@ post-configure:
pre-install:
@-${X11BASE}/bin/gconftool --shutdown
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/galeon/files/patch-src_mozilla_TOCProtocolHandler.cpp b/www/galeon/files/patch-src_mozilla_TOCProtocolHandler.cpp
new file mode 100644
index 000000000000..8a63aaa3b565
--- /dev/null
+++ b/www/galeon/files/patch-src_mozilla_TOCProtocolHandler.cpp
@@ -0,0 +1,11 @@
+--- src/mozilla/TOCProtocolHandler.cpp.orig Sun Jun 16 14:02:36 2002
++++ src/mozilla/TOCProtocolHandler.cpp Sun Jun 16 14:11:48 2002
+@@ -400,7 +400,7 @@
+ nsresult rv;
+
+ struct dirent **namelist;
+- int n = scandir (SHARE_DIR"/../gnome/help", &namelist, select,
++ int n = scandir (SHARE_DIR"/../gnome/help", &namelist, ((int(*)(struct dirent *))select),
+ alphasort);
+ if (n<0) return NS_ERROR_FAILURE;
+
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 6eb3a1f4cda5..b59b68ed1067 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -41,6 +41,14 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+# Galeon does not build correctly in -CURRENT if -Werror is passed
+# to the compiler.
+CONFIGURE_ARGS+= --disable-werror
+.endif
+
post-extract:
.if !defined(WITH_FULL_MOZILLA)
@${ECHO_MSG}
@@ -69,4 +77,4 @@ post-configure:
pre-install:
@-${X11BASE}/bin/gconftool --shutdown
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/galeon2/files/patch-src_mozilla_TOCProtocolHandler.cpp b/www/galeon2/files/patch-src_mozilla_TOCProtocolHandler.cpp
new file mode 100644
index 000000000000..8a63aaa3b565
--- /dev/null
+++ b/www/galeon2/files/patch-src_mozilla_TOCProtocolHandler.cpp
@@ -0,0 +1,11 @@
+--- src/mozilla/TOCProtocolHandler.cpp.orig Sun Jun 16 14:02:36 2002
++++ src/mozilla/TOCProtocolHandler.cpp Sun Jun 16 14:11:48 2002
+@@ -400,7 +400,7 @@
+ nsresult rv;
+
+ struct dirent **namelist;
+- int n = scandir (SHARE_DIR"/../gnome/help", &namelist, select,
++ int n = scandir (SHARE_DIR"/../gnome/help", &namelist, ((int(*)(struct dirent *))select),
+ alphasort);
+ if (n<0) return NS_ERROR_FAILURE;
+