aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-10-28 14:09:54 +0800
committerWill Andrews <will@FreeBSD.org>2000-10-28 14:09:54 +0800
commit42fadda09cc26aa7e0d82aab86cc2242789551ca (patch)
tree3b8fe71de74f8e119e53e1e7f17bfdce4f2cc73f /www
parent9c52298bb96bbebe44e36f3cf4fd05fed66bc9ce (diff)
downloadfreebsd-ports-42fadda09cc26aa7e0d82aab86cc2242789551ca.tar.gz
freebsd-ports-42fadda09cc26aa7e0d82aab86cc2242789551ca.tar.zst
freebsd-ports-42fadda09cc26aa7e0d82aab86cc2242789551ca.zip
Add webredirect 0.1, an extremely simple webserver that only performs
redirections for a limited number of HTTP commands. PR: 22273 Submitted by: Rasmus Kaj <kaj@Raditex.se>
Notes
Notes: svn path=/head/; revision=34340
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webredirect/Makefile26
-rw-r--r--www/webredirect/distinfo1
-rw-r--r--www/webredirect/pkg-comment1
-rw-r--r--www/webredirect/pkg-descr9
-rw-r--r--www/webredirect/pkg-message4
-rw-r--r--www/webredirect/pkg-plist1
7 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 218ec95a4f31..ca2638ecc67a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -193,6 +193,7 @@
SUBDIR += webfs
SUBDIR += webglimpse
SUBDIR += weblint
+ SUBDIR += webredirect
SUBDIR += webstone
SUBDIR += wml
SUBDIR += wmnetselect
diff --git a/www/webredirect/Makefile b/www/webredirect/Makefile
new file mode 100644
index 000000000000..9d7895aacc36
--- /dev/null
+++ b/www/webredirect/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: webredirect
+# Date created: 24 October 2000
+# Whom: kaj@Raditex.se
+#
+# $FreeBSD$
+#
+
+PORTNAME= webredirect
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.Raditex.se/pub/kaj/
+
+MAINTAINER= kaj@Raditex.se
+
+MAN1= webredirect.1
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/webredirect ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/webredirect.1 ${PREFIX}/man/man1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/webredirect/distinfo b/www/webredirect/distinfo
new file mode 100644
index 000000000000..5cb83dd17541
--- /dev/null
+++ b/www/webredirect/distinfo
@@ -0,0 +1 @@
+MD5 (webredirect-0.1.tar.gz) = 91006560caaa6aaa4203ee7bd00d36a4
diff --git a/www/webredirect/pkg-comment b/www/webredirect/pkg-comment
new file mode 100644
index 000000000000..63b02efa837f
--- /dev/null
+++ b/www/webredirect/pkg-comment
@@ -0,0 +1 @@
+Small web server serving "301 Moved Permanently" only
diff --git a/www/webredirect/pkg-descr b/www/webredirect/pkg-descr
new file mode 100644
index 000000000000..602c5f79f18f
--- /dev/null
+++ b/www/webredirect/pkg-descr
@@ -0,0 +1,9 @@
+The webredirect program is an extremely small web server that gives the
+"301 Moved Permanently" response to all "GET", "HEAD" and "POST" respons-
+es. At the moment, all other requests are unsupported and result in a
+"501 Not Supported" response.
+
+WWW: http://Raditex.se/opensrc/
+
+- Rasmus Kaj
+kaj@Raditex.se
diff --git a/www/webredirect/pkg-message b/www/webredirect/pkg-message
new file mode 100644
index 000000000000..13d0b628334c
--- /dev/null
+++ b/www/webredirect/pkg-message
@@ -0,0 +1,4 @@
+Webredirect is installed but does not start automatically. Read the manpage
+to find out what options you like. Then start webredirect manually. If you
+want webredirect to start automatically on boot, create a small script in
+/usr/local/etc/rc.d to do so.
diff --git a/www/webredirect/pkg-plist b/www/webredirect/pkg-plist
new file mode 100644
index 000000000000..22d1f1f8ff42
--- /dev/null
+++ b/www/webredirect/pkg-plist
@@ -0,0 +1 @@
+bin/webredirect