aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-09-11 20:51:34 +0800
committerMartin Blapp <mbr@FreeBSD.org>2002-09-11 20:51:34 +0800
commitf0dbe5a9164a7f0f8c6a5f6c647d37fbef0b4de2 (patch)
tree573e8c2520f47d40309d7784401229bd2e066d91 /www
parentaaa10d7ab71976e428d2e131d1207287afc01280 (diff)
downloadfreebsd-ports-f0dbe5a9164a7f0f8c6a5f6c647d37fbef0b4de2.tar.gz
freebsd-ports-f0dbe5a9164a7f0f8c6a5f6c647d37fbef0b4de2.tar.zst
freebsd-ports-f0dbe5a9164a7f0f8c6a5f6c647d37fbef0b4de2.zip
Unbreak port on stable. Apxs was hardcoded in the Makefile.
Notes
Notes: svn path=/head/; revision=66123
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_mysql_another/Makefile5
-rw-r--r--www/mod_auth_mysql_another/files/patch-Makefile4
2 files changed, 6 insertions, 3 deletions
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 831c3599fbc6..f37f3dde0e4a 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -59,7 +59,10 @@ do-extract:
post-patch:
@${CP} ${WRKDIR}/mod_auth_mysql/Makefile ${WRKDIR}/mod_auth_mysql/Makefile.new
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' < ${WRKDIR}/mod_auth_mysql/Makefile.new \
+ @(${SED} -e 's|%%PREFIX%%|${PREFIX}|g' | \
+ ${SED} -e 's|%%APXS%%|${APXS}|g' | \
+ ${SED} -e 's|%%APXSFLAGS%%|${APXSFLAGS}|g') \
+ < ${WRKDIR}/mod_auth_mysql/Makefile.new \
> ${WRKDIR}/mod_auth_mysql/Makefile
post-install:
diff --git a/www/mod_auth_mysql_another/files/patch-Makefile b/www/mod_auth_mysql_another/files/patch-Makefile
index 7f797afafccf..62665ace52a6 100644
--- a/www/mod_auth_mysql_another/files/patch-Makefile
+++ b/www/mod_auth_mysql_another/files/patch-Makefile
@@ -1,8 +1,8 @@
--- /dev/null Sat Apr 20 17:11:40 2002
+++ Makefile Sat Apr 20 17:12:22 2002
@@ -0,0 +1,17 @@
-+APXS = apxs
-+APXSFLAGS =
++APXS = %%APXS%%
++APXSFLAGS = %%APXSFLAGS%%
+DSO = mod_auth_mysql.so
+SRCS = mod_auth_mysql.c
+OPTS = -I%%PREFIX%%/include -L%%PREFIX%%/lib/mysql -lmysqlclient