aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gnustep-back
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2019-02-03 23:37:58 +0800
committerDavid Chisnall <theraven@FreeBSD.org>2019-02-03 23:37:58 +0800
commit3f627ab4ceb27d868b1d614957e04bfa927d165b (patch)
tree8d55e3d4d3e216787ab6284b0e649a7a6d2f047d /x11-toolkits/gnustep-back
parent6f24a15624ece550a72b46b91ed993a1f8a1d7ee (diff)
downloadfreebsd-ports-3f627ab4ceb27d868b1d614957e04bfa927d165b.tar.gz
freebsd-ports-3f627ab4ceb27d868b1d614957e04bfa927d165b.tar.zst
freebsd-ports-3f627ab4ceb27d868b1d614957e04bfa927d165b.zip
Move Objective-C ports to the v2 GNUstep ABI.
* Bump the LLVM revision used for GNUstep to 7, the minimum to support the new ABI. * GNUstep-back does not work with lld, so mark it to use Gold (BFD LD doesn't seem able to link Objective-C things). * Turn off some annoying debug logs in GNUstep back, which generate several messages per second when you move the mouse. These should never have been enabled in a release build anyway. * Downgrade Cenon to 4.0.2. This was the last version to actually work with GNUstep (the later ones use XCode >= 5 .xib files, which GNUstep can't parse). * Update gorm to git head. The current release doesn't work with the new Objective-C ABI, but -head has the patches to fix it. * Update PikoPixel and add it to the gnustep-app meta-package. * Update the three core GNUstep packages to the latest release. * Update gnumail and pantomime to the latest release and fix a linking error with the new ABI. * Update GNUstep FTP to the latest version. Reviewed by: bapt (previous version)
Notes
Notes: svn path=/head/; revision=492056
Diffstat (limited to 'x11-toolkits/gnustep-back')
-rw-r--r--x11-toolkits/gnustep-back/Makefile18
-rw-r--r--x11-toolkits/gnustep-back/distinfo6
2 files changed, 16 insertions, 8 deletions
diff --git a/x11-toolkits/gnustep-back/Makefile b/x11-toolkits/gnustep-back/Makefile
index 1d2dd4e43b43..135816091c69 100644
--- a/x11-toolkits/gnustep-back/Makefile
+++ b/x11-toolkits/gnustep-back/Makefile
@@ -1,10 +1,13 @@
# $FreeBSD$
PORTNAME= gnustep-back
-PORTVERSION= 0.25.1
-PORTREVISION= 2
+PORTVERSION= 0.27.0
CATEGORIES= x11-toolkits gnustep
-MASTER_SITES= GNUSTEP/core
+
+USE_GITHUB= yes
+GH_ACCOUNT= gnustep
+GH_PROJECT= libs-back
+GH_TAGNAME= back-${PORTVERSION:S/./_/g}
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep GUI backend
@@ -29,11 +32,16 @@ CONFIGURE_ARGS= --with-tiff-library=${LOCALBASE}/lib \
--enable-graphics=cairo \
--disable-glitz
-USES= gnustep jpeg pkgconfig
+USES= gnustep jpeg pkgconfig gl
USE_GNUSTEP= base gui build
USE_XORG= xft xrender xmu xext x11 xcursor xfixes xmu
-USE_GL= yes
+USE_GL= gl
USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
+# LLD 7 creates a library that does not work with FreeBSD (or OpenBSD) rtld -
+# it loads apparently without errors, but the global constructors are not
+# called. It also appears to corrupt some internal state, as throwing an
+# exception causes a crash inside rtld.
+LLD_UNSAFE= yes
MAKE_FLAGS+= OPTFLAG="${CFLAGS} -I${LOCALBASE}/include"
BACKVERSION= ${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
diff --git a/x11-toolkits/gnustep-back/distinfo b/x11-toolkits/gnustep-back/distinfo
index 85e7327da6d2..d4099c95ab91 100644
--- a/x11-toolkits/gnustep-back/distinfo
+++ b/x11-toolkits/gnustep-back/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1495189160
-SHA256 (gnustep-back-0.25.1.tar.gz) = ea563b7d6e4bd8b13856306c94bfe06b0909b71e62ab70dccf1c208f4889e2bf
-SIZE (gnustep-back-0.25.1.tar.gz) = 974775
+TIMESTAMP = 1549125286
+SHA256 (gnustep-libs-back-0.27.0-back-0_27_0_GH0.tar.gz) = 0f095566f37417a67a5922b9270caba3da6e87f72612bc678a7e73c659fb8ebc
+SIZE (gnustep-libs-back-0.27.0-back-0_27_0_GH0.tar.gz) = 972187