aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-11 01:06:18 +0800
committerWill Andrews <will@FreeBSD.org>2001-03-11 01:06:18 +0800
commit847680b774181a85da8dad70009c2d329aac8f96 (patch)
tree57dceb20bb362a5e5bc7a6bc8de3bf4c976250db /x11-toolkits
parentf800720c00547b8d7f1fd0b1b027a9a9ea4581bf (diff)
downloadfreebsd-ports-847680b774181a85da8dad70009c2d329aac8f96.tar.gz
freebsd-ports-847680b774181a85da8dad70009c2d329aac8f96.tar.zst
freebsd-ports-847680b774181a85da8dad70009c2d329aac8f96.zip
Fix build for alpha.
Found/Confirmed by: steve Fix submitted by: gallatin
Notes
Notes: svn path=/head/; revision=39433
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt22/Makefile8
-rw-r--r--x11-toolkits/qt23/Makefile8
-rw-r--r--x11-toolkits/qt30/Makefile8
-rw-r--r--x11-toolkits/qt31/Makefile8
-rw-r--r--x11-toolkits/qt32/Makefile8
-rw-r--r--x11-toolkits/qt33/Makefile8
6 files changed, 42 insertions, 6 deletions
diff --git a/x11-toolkits/qt22/Makefile b/x11-toolkits/qt22/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt22/Makefile
+++ b/x11-toolkits/qt22/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 894ac26c5603..7d1e5e4ea966 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -48,6 +48,12 @@ STATIC=shared
INSTALLS_SHLIB=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -O0
+.endif
+
pre-fetch:
.if exists(${X11BASE}/lib/libqt2.so.3)
.if !defined(WANT_STATIC)
@@ -124,4 +130,4 @@ post-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>