aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
committerSatoshi Asami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
commitc6bcad2436d925c98052ed292bd0794ae0e34b45 (patch)
tree4752ebd6e8eb5959ebf00516e4ecf7156215bbce /x11-toolkits
parentfbd121eee966abfc21d176cbede935ecd6bf1a34 (diff)
downloadfreebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.gz
freebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.zst
freebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Notes
Notes: svn path=/head/; revision=31272
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/FWF/Makefile3
-rw-r--r--x11-toolkits/fltk/Makefile3
-rw-r--r--x11-toolkits/fox-devel/Makefile4
-rw-r--r--x11-toolkits/fox/Makefile4
-rw-r--r--x11-toolkits/fox10/Makefile4
-rw-r--r--x11-toolkits/fox14/Makefile4
-rw-r--r--x11-toolkits/gtk13/Makefile2
-rw-r--r--x11-toolkits/gtk20/Makefile2
-rw-r--r--x11-toolkits/gtk30/Makefile2
-rw-r--r--x11-toolkits/gtkglarea/Makefile4
-rw-r--r--x11-toolkits/gtkglarea2/Makefile4
-rw-r--r--x11-toolkits/jx/Makefile4
-rw-r--r--x11-toolkits/plib/Makefile7
-rw-r--r--x11-toolkits/tkstep80/Makefile2
14 files changed, 23 insertions, 26 deletions
diff --git a/x11-toolkits/FWF/Makefile b/x11-toolkits/FWF/Makefile
index 11dc6076d917..ec33d1730161 100644
--- a/x11-toolkits/FWF/Makefile
+++ b/x11-toolkits/FWF/Makefile
@@ -14,14 +14,13 @@ MASTER_SITE_SUBDIR=libs/X/fwf
MAINTAINER= jseger@FreeBSD.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-
.if ${MACHINE_ARCH} == "alpha"
BROKEN= ../../lib/libfwf.a: cannot read symbols
.endif
REQUIRES_MOTIF= yes
USE_IMAKE= yes
+USE_XPM= yes
WRKSRC= ${WRKDIR}/FWF
XMKMF= ${SETENV} X11BASE=${X11BASE} WRKSRC=${WRKSRC} sh ${FILESDIR}/xmkmf
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 20eeb7a5ccbf..1717ee91ccc6 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -18,8 +18,6 @@ DISTNAME= ${PKGNAME}-source
MAINTAINER= dima@chg.ru
-LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
-
VERSION= 1.0.9
USE_BZIP2= yes
INSTALLS_SHLIB= yes
@@ -27,6 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
WRKSRC= ${WRKDIR}/${PKGNAME}
USE_X_PREFIX= yes
+USE_MESA= yes
MAN1= fluid.1
post-install:
diff --git a/x11-toolkits/fox-devel/Makefile b/x11-toolkits/fox-devel/Makefile
index 9377caa92da2..d435d5ce0f59 100644
--- a/x11-toolkits/fox-devel/Makefile
+++ b/x11-toolkits/fox-devel/Makefile
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.4:${PORTSDIR}/graphics/png \
- GL.14:${PORTSDIR}/graphics/Mesa3
+ png.4:${PORTSDIR}/graphics/png
+USE_MESA= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index 9377caa92da2..d435d5ce0f59 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.4:${PORTSDIR}/graphics/png \
- GL.14:${PORTSDIR}/graphics/Mesa3
+ png.4:${PORTSDIR}/graphics/png
+USE_MESA= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index 9377caa92da2..d435d5ce0f59 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.4:${PORTSDIR}/graphics/png \
- GL.14:${PORTSDIR}/graphics/Mesa3
+ png.4:${PORTSDIR}/graphics/png
+USE_MESA= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 9377caa92da2..d435d5ce0f59 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -15,9 +15,9 @@ MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.4:${PORTSDIR}/graphics/png \
- GL.14:${PORTSDIR}/graphics/Mesa3
+ png.4:${PORTSDIR}/graphics/png
+USE_MESA= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-opengl=mesa --with-x
diff --git a/x11-toolkits/gtk13/Makefile b/x11-toolkits/gtk13/Makefile
index 491e7987435c..82c10ac5ab5a 100644
--- a/x11-toolkits/gtk13/Makefile
+++ b/x11-toolkits/gtk13/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= glib-1.3.1:${PORTSDIR}/devel/glib13 \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_XPM= yes
USE_PERL5= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 491e7987435c..82c10ac5ab5a 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= glib-1.3.1:${PORTSDIR}/devel/glib13 \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_XPM= yes
USE_PERL5= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 491e7987435c..82c10ac5ab5a 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= glib-1.3.1:${PORTSDIR}/devel/glib13 \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- Xpm.4:${PORTSDIR}/graphics/xpm \
intl.1:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_XPM= yes
USE_PERL5= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkglarea/Makefile b/x11-toolkits/gtkglarea/Makefile
index 09da0f535bb6..3fb37b44e803 100644
--- a/x11-toolkits/gtkglarea/Makefile
+++ b/x11-toolkits/gtkglarea/Makefile
@@ -12,11 +12,11 @@ MASTER_SITES= http://www.student.oulu.fi/~jlof/gtkglarea/download/
MAINTAINER= jaeger16@yahoo.com
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- GL.14:${PORTSDIR}/graphics/Mesa3
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+USE_MESA= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
diff --git a/x11-toolkits/gtkglarea2/Makefile b/x11-toolkits/gtkglarea2/Makefile
index 09da0f535bb6..3fb37b44e803 100644
--- a/x11-toolkits/gtkglarea2/Makefile
+++ b/x11-toolkits/gtkglarea2/Makefile
@@ -12,11 +12,11 @@ MASTER_SITES= http://www.student.oulu.fi/~jlof/gtkglarea/download/
MAINTAINER= jaeger16@yahoo.com
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- GL.14:${PORTSDIR}/graphics/Mesa3
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+USE_MESA= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
diff --git a/x11-toolkits/jx/Makefile b/x11-toolkits/jx/Makefile
index 042e5cf41b46..e461403ea675 100644
--- a/x11-toolkits/jx/Makefile
+++ b/x11-toolkits/jx/Makefile
@@ -16,12 +16,12 @@ DISTNAME= ${PORTNAME}_source-${PORTVERSION}
MAINTAINER= lioux@linf.unb.br
-LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
- Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
+USE_XPM= yes
INSTALLS_SHLIB= yes
USE_BISON= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/plib/Makefile b/x11-toolkits/plib/Makefile
index 19d5ad507d1d..277020daf31d 100644
--- a/x11-toolkits/plib/Makefile
+++ b/x11-toolkits/plib/Makefile
@@ -12,12 +12,11 @@ MASTER_SITES= http://plib.sourceforge.net/dist/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
-
USE_X_PREFIX= yes
+USE_MESA= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS=-I${X11BASE}/include
-CONFIGURE_ARGS+= --includedir=$(PREFIX)/include/plib \
+CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include
+CONFIGURE_ARGS= --includedir=$(PREFIX)/include/plib \
--with-glut=${PREFIX}
USE_GMAKE= yes
USE_NEWGCC= yes
diff --git a/x11-toolkits/tkstep80/Makefile b/x11-toolkits/tkstep80/Makefile
index 7287f77f9330..c7c714ec4703 100644
--- a/x11-toolkits/tkstep80/Makefile
+++ b/x11-toolkits/tkstep80/Makefile
@@ -17,11 +17,11 @@ PATCHFILES= tk8.0.4-to-tkstep8.0.4-2.patch.tar.gz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80 \
- Xpm.4:${PORTSDIR}/graphics/xpm \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
FILE_DEPENDS= ${PORTSDIR}/x11-toolkits/tk80
+USE_XPM= yes
FETCH_BEFORE_ARGS= -b
PATCH_DIST_ARGS= -p1 -d ${WRKDIR}/tk8.0.4 -E --quiet
WRKSRC= ${WRKDIR}/tk8.0.4/unix