aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2009-02-23 06:41:40 +0800
committerkwm <kwm@FreeBSD.org>2009-02-23 06:41:40 +0800
commitdeedd55b51d7aec36aa9a72274c698f007fcc4d5 (patch)
tree85f8df4f0be386ee46f398223f35c7b113da3a4b /x11-toolkits
parent188c9ed8a31fc1b405c6f37dc9c2ab3c2a5735e8 (diff)
downloadfreebsd-ports-deedd55b51d7aec36aa9a72274c698f007fcc4d5.tar.gz
freebsd-ports-deedd55b51d7aec36aa9a72274c698f007fcc4d5.tar.zst
freebsd-ports-deedd55b51d7aec36aa9a72274c698f007fcc4d5.zip
Add unique.
Unique is a library for writing single instance application. If you launch a single instance application twice, the second instance will either just quit or will send a message to the running instance. Unique makes it easy to write this kind of applications, by providing a base class, taking care of all the IPC machinery needed to send messages to a running instance, and also handling the startup notification side.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/unique/Makefile32
-rw-r--r--x11-toolkits/unique/distinfo3
-rw-r--r--x11-toolkits/unique/pkg-descr12
-rw-r--r--x11-toolkits/unique/pkg-plist29
5 files changed, 77 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index d73d843f046b..c4fe6057d3c2 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -271,6 +271,7 @@
SUBDIR += tktable
SUBDIR += tktray
SUBDIR += tktreectrl
+ SUBDIR += unique
SUBDIR += v
SUBDIR += vdk
SUBDIR += vdkbuilder
diff --git a/x11-toolkits/unique/Makefile b/x11-toolkits/unique/Makefile
new file mode 100644
index 000000000000..45aa48028b2b
--- /dev/null
+++ b/x11-toolkits/unique/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libunique
+# Date created: 22 Feb 2009
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom$
+#
+
+PORTNAME= unique
+PORTVERSION= 1.0.6
+CATEGORIES= devel
+MASTER_SITES= http://www.gnome.org/~ebassi/source/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library for single instance applications.
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
+
+USE_XORG= ice
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= glib20 gnomeprefix
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/unique/distinfo b/x11-toolkits/unique/distinfo
new file mode 100644
index 000000000000..08da782dbfe6
--- /dev/null
+++ b/x11-toolkits/unique/distinfo
@@ -0,0 +1,3 @@
+MD5 (unique-1.0.6.tar.gz) = 90eccdb97722d53f872a8fbdc8255ebb
+SHA256 (unique-1.0.6.tar.gz) = 5ab4814e854f594dd004b07bdecffd360f81cd13482d850d9c99e8b4cc9191b9
+SIZE (unique-1.0.6.tar.gz) = 449242
diff --git a/x11-toolkits/unique/pkg-descr b/x11-toolkits/unique/pkg-descr
new file mode 100644
index 000000000000..01b9245662a2
--- /dev/null
+++ b/x11-toolkits/unique/pkg-descr
@@ -0,0 +1,12 @@
+Unique is a library for writing single instance application. If you launch a
+single instance application twice, the second instance will either just quit
+or will send a message to the running instance.
+
+Unique makes it easy to write this kind of applications, by providing a base
+class, taking care of all the IPC machinery needed to send messages to a
+running instance, and also handling the startup notification side.
+
+Unique aims to replace the BaconMessageConnection code that has been copied
+by many projects and the code using Bonobo and D-Bus.
+
+WWW: http://live.gnome.org/LibUnique
diff --git a/x11-toolkits/unique/pkg-plist b/x11-toolkits/unique/pkg-plist
new file mode 100644
index 000000000000..fada9ed4463b
--- /dev/null
+++ b/x11-toolkits/unique/pkg-plist
@@ -0,0 +1,29 @@
+include/unique-1.0/unique/unique.h
+include/unique-1.0/unique/uniqueapp.h
+include/unique-1.0/unique/uniquebackend.h
+include/unique-1.0/unique/uniquemessage.h
+include/unique-1.0/unique/uniqueversion.h
+lib/libunique-1.0.a
+lib/libunique-1.0.la
+lib/libunique-1.0.so
+lib/libunique-1.0.so.2
+libdata/pkgconfig/unique-1.0.pc
+%%DOCSDIR%%/UniqueApp.html
+%%DOCSDIR%%/UniqueBackend.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/ix01.html
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/license.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/unique-Message-Data.html
+%%DOCSDIR%%/unique-Versioning-Information.html
+%%DOCSDIR%%/unique-overview.html
+%%DOCSDIR%%/unique.devhelp
+%%DOCSDIR%%/unique.devhelp2
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
+@dirrm include/unique-1.0/unique
+@dirrm include/unique-1.0