aboutsummaryrefslogtreecommitdiffstats
path: root/x11/mlterm
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2008-05-11 21:22:35 +0800
committernobutaka <nobutaka@FreeBSD.org>2008-05-11 21:22:35 +0800
commit96327ee1d5cd484b4ff3b9c5a80839ee68a7cc60 (patch)
treecc1210c8cd7397c645a38d99707cd7dc7e465d54 /x11/mlterm
parent9ec35d7a1b51a5c33a566e08e4bfaea7937e0bcf (diff)
downloadfreebsd-ports-96327ee1d5cd484b4ff3b9c5a80839ee68a7cc60.tar.gz
freebsd-ports-96327ee1d5cd484b4ff3b9c5a80839ee68a7cc60.tar.zst
freebsd-ports-96327ee1d5cd484b4ff3b9c5a80839ee68a7cc60.zip
- Chase libuim shared library version bump.
- Fix build error for WITH_UIM.
Diffstat (limited to 'x11/mlterm')
-rw-r--r--x11/mlterm/Makefile2
-rw-r--r--x11/mlterm/files/patch-inputmethod_uim_im_uim.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 603aaf1f1584..1f487fd7f55e 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -45,7 +45,7 @@ CONFIGURE_ARGS+= --disable-fribidi
.if defined(WITH_UIM)
CONFIGURE_ARGS+= --enable-uim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
-LIB_DEPENDS+= uim.5:${PORTSDIR}/textproc/uim
+LIB_DEPENDS+= uim.6:${PORTSDIR}/textproc/uim
PLIST_SUB+= UIM=""
.else
CONFIGURE_ARGS+= --disable-uim
diff --git a/x11/mlterm/files/patch-inputmethod_uim_im_uim.c b/x11/mlterm/files/patch-inputmethod_uim_im_uim.c
new file mode 100644
index 000000000000..f772f0ad2fb1
--- /dev/null
+++ b/x11/mlterm/files/patch-inputmethod_uim_im_uim.c
@@ -0,0 +1,10 @@
+--- inputmethod/uim/im_uim.c.orig 2008-05-07 21:49:29.000000000 +0900
++++ inputmethod/uim/im_uim.c 2008-05-07 21:51:50.000000000 +0900
+@@ -35,6 +35,7 @@
+ #include <uim-helper.h>
+ #include <uim-im-switcher.h>
+
++#include <stdio.h>
+ #include <X11/keysym.h> /* XK_xxx */
+ #include <kiklib/kik_mem.h> /* malloc/alloca/free */
+ #include <kiklib/kik_str.h> /* kik_str_alloca_dup kik_str_sep kik_snprintf*/