aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2001-06-07 08:15:42 +0800
committerJean-Marc Zucconi <jmz@FreeBSD.org>2001-06-07 08:15:42 +0800
commit28a6b2d95fc5cde725272872524cdb7820803b32 (patch)
tree76d43efa4017c358d74023eb03cc3836288d6499 /x11
parentc3874c8b4476a9a613c08652239f21527eeb68ca (diff)
downloadfreebsd-ports-28a6b2d95fc5cde725272872524cdb7820803b32.tar.gz
freebsd-ports-28a6b2d95fc5cde725272872524cdb7820803b32.tar.zst
freebsd-ports-28a6b2d95fc5cde725272872524cdb7820803b32.zip
Update the port to 4.1.6, based on the Debian version; use installed jpeg
and tiff libraries and add png support. Submitted by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=43570
Diffstat (limited to 'x11')
-rw-r--r--x11/xloadimage/Makefile42
-rw-r--r--x11/xloadimage/distinfo1
-rw-r--r--x11/xloadimage/files/patch-110
-rw-r--r--x11/xloadimage/files/patch-212
-rw-r--r--x11/xloadimage/files/patch-310
-rw-r--r--x11/xloadimage/files/patch-411
-rw-r--r--x11/xloadimage/files/patch-530
-rw-r--r--x11/xloadimage/files/patch-611
-rw-r--r--x11/xloadimage/files/patch-712
-rw-r--r--x11/xloadimage/files/patch-Makefile.in11
-rw-r--r--x11/xloadimage/files/patch-xloadimage.man10
-rw-r--r--x11/xloadimage/pkg-descr1
-rw-r--r--x11/xloadimage/pkg-plist6
13 files changed, 59 insertions, 108 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 3338db49628d..5d472ff8bc2b 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -5,27 +5,47 @@
# $FreeBSD$
#
+VERSION= 4.1
+REVISION= 6
+
PORTNAME= xloadimage
-PORTVERSION= 4.1
-CATEGORIES= x11
+PORTVERSION= ${VERSION}.${REVISION}
+CATEGORIES= x11 graphics
MASTER_SITES= ftp://ftp.x.org/R5contrib/ \
ftp://ftp.freesoftware.com/pub/X11/R5contrib/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+DISTNAME= ${PORTNAME}.${VERSION}
+PATCH_SITES= ftp://ftp.debian.org/debian/pool/main/x/xloadimage/ \
+ ftp://ftp.de.debian.org/debian/pool/main/x/xloadimage/
+PATCHFILES= xloadimage_${VERSION}-${REVISION}.diff.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= jmz@FreeBSD.org
-USE_X_PREFIX= yes
-ALL_TARGET=
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.4:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+ LDFLAGS=-L${LOCALBASE}/lib
+
MAN1= xloadimage.1 uufilter.1
+MLINKS= xloadimage.1 xsetbg.1 \
+ xloadimage.1 xview.1
-do-configure:
- cd ${WRKSRC} && ${MAKE} configure </dev/null
- cd ${WRKSRC} && ${ECHO} SYSPATHFILE=${PREFIX}/lib/X11/app-defaults/Xloadimage >> Makefile
+post-patch:
+ @chmod a+rx ${WRKSRC}/configure
do-install:
- cd ${WRKSRC} && ${INSTALL_PROGRAM} xloadimage uufilter ${PREFIX}/bin
- cd ${WRKSRC} && ${INSTALL_DATA} xloadimagerc ${PREFIX}/lib/X11/app-defaults/Xloadimage
- cd ${WRKSRC} && ${SED} -e s:/usr/lib/X11/Xloadimage:${PREFIX}/lib/X11/app-defaults/Xloadimage: < xloadimage.man >${PREFIX}/man/man1/xloadimage.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xloadimage ${PREFIX}/bin
+ @cd ${PREFIX}/bin && \
+ ln -sf xloadimage xsetbg && \
+ ln -sf xloadimage xview
+ ${INSTALL_PROGRAM} ${WRKSRC}/uufilter ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xloadimage.man ${PREFIX}/man/man1/xloadimage.1
${INSTALL_MAN} ${WRKSRC}/uufilter.man ${PREFIX}/man/man1/uufilter.1
+ mkdir -p ${PREFIX}/share/examples/xloadimage
+ ${INSTALL_DATA} ${WRKSRC}/xloadimagerc \
+ ${PREFIX}/share/examples/xloadimage/xloadimagerc
.include <bsd.port.mk>
diff --git a/x11/xloadimage/distinfo b/x11/xloadimage/distinfo
index 1dab3bfe5828..d4ea53eb3cf3 100644
--- a/x11/xloadimage/distinfo
+++ b/x11/xloadimage/distinfo
@@ -1 +1,2 @@
MD5 (xloadimage.4.1.tar.gz) = 7331850fc04056ab8ae6b5725d1fb3d2
+MD5 (xloadimage_4.1-6.diff.gz) = 37d6d6d7108ed53e83b160111b883b54
diff --git a/x11/xloadimage/files/patch-1 b/x11/xloadimage/files/patch-1
deleted file mode 100644
index 29b9b9e7635f..000000000000
--- a/x11/xloadimage/files/patch-1
+++ /dev/null
@@ -1,10 +0,0 @@
---- window.c~ Mon Nov 8 22:06:02 1993
-+++ window.c Tue Jun 9 01:51:46 1998
-@@ -9,7 +9,6 @@
- */
-
- #include "copyright.h"
--#include <ctype.h>
- #include "xloadimage.h"
- #include <X11/cursorfont.h>
- #include <X11/Xatom.h>
diff --git a/x11/xloadimage/files/patch-2 b/x11/xloadimage/files/patch-2
deleted file mode 100644
index 3787fc43c9b3..000000000000
--- a/x11/xloadimage/files/patch-2
+++ /dev/null
@@ -1,12 +0,0 @@
---- config.c~ Thu Oct 28 17:37:46 1993
-+++ config.c Tue Jun 9 01:51:08 1998
-@@ -9,8 +9,8 @@
- */
-
- #include "copyright.h"
--#include <ctype.h> /* must here for debugging version under AIX */
- #include "xloadimage.h"
-+#undef X_NOT_STDC_ENV
- #include <X11/Xos.h>
- #include <sys/stat.h>
- #ifndef VMS
diff --git a/x11/xloadimage/files/patch-3 b/x11/xloadimage/files/patch-3
deleted file mode 100644
index c6e9850fd417..000000000000
--- a/x11/xloadimage/files/patch-3
+++ /dev/null
@@ -1,10 +0,0 @@
---- image.h~ Thu Oct 28 19:14:56 1993
-+++ image.h Tue Jun 9 01:45:59 1998
-@@ -20,7 +20,6 @@
- #define _ArgProto(ARGS) ARGS
- #endif
-
--#include <stdlib.h>
-
- #else /* !__STDC__ */
-
diff --git a/x11/xloadimage/files/patch-4 b/x11/xloadimage/files/patch-4
deleted file mode 100644
index e1f4c33e2d55..000000000000
--- a/x11/xloadimage/files/patch-4
+++ /dev/null
@@ -1,11 +0,0 @@
---- tiff/tiffcompat.h~ Tue Nov 2 22:31:40 1993
-+++ tiff/tiffcompat.h Tue Jun 9 02:06:32 1998
-@@ -151,8 +151,6 @@
- #ifdef applec
- #define lseek mpw_lseek
- extern long mpw_lseek(int, long, int);
--#else
--extern long lseek();
- #endif
-
- /*
diff --git a/x11/xloadimage/files/patch-5 b/x11/xloadimage/files/patch-5
deleted file mode 100644
index fed5afff4d34..000000000000
--- a/x11/xloadimage/files/patch-5
+++ /dev/null
@@ -1,30 +0,0 @@
---- merge.c.orig Thu Oct 21 22:28:39 1993
-+++ merge.c Sun Dec 12 03:25:45 1999
-@@ -244,6 +244,7 @@
- int x, y;
- unsigned int width, height, verbose;
- { Image *base, *tmp;
-+ int ycur = y;
-
- if (verbose) {
- printf(" Tiling...");
-@@ -260,15 +261,16 @@
- base = newTrueImage(width, height);
-
- while (x < base->width) {
-- while(y < base->height) {
-- tmp = merge(base, image, x, y, 0);
-+ while(ycur < base->height) {
-+ tmp = merge(base, image, x, ycur, 0);
- if (tmp != base) {
- freeImage(base);
- base = tmp;
- }
-- y += image->width;
-+ ycur += image->width;
- }
- x += image->width;
-+ ycur = y;
- }
- printf("done.\n");
- return(base);
diff --git a/x11/xloadimage/files/patch-6 b/x11/xloadimage/files/patch-6
deleted file mode 100644
index b2cb0f1cc85e..000000000000
--- a/x11/xloadimage/files/patch-6
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile Tue Nov 9 17:25:12 1993
-+++ Makefile Sun Jul 2 10:56:48 2000
-@@ -24,5 +24,7 @@
-
- autoconfig: autoconfig.c
-- $(CC) -g -o autoconfig autoconfig.c
-+ $(CC) -o autoconfig autoconfig.c -DDEF_CC='"${CC}"' \
-+ -DDEF_OPT_FLAGS='"${OPT_FLAGS}"' \
-+ -DDEF_INSTALL_DIR='"${PREFIX}/bin"'
-
- # manual configuration target
diff --git a/x11/xloadimage/files/patch-7 b/x11/xloadimage/files/patch-7
deleted file mode 100644
index bca1abcecd88..000000000000
--- a/x11/xloadimage/files/patch-7
+++ /dev/null
@@ -1,12 +0,0 @@
---- Make.conf Tue Nov 9 17:26:55 1993
-+++ Make.conf Sun Jul 2 10:57:03 2000
-@@ -12,5 +12,8 @@
-
- # Optimization flags for C compiler.
--OPT_FLAGS=
-+# A comment inside autoconfig.c recommends the two extra options:
-+# -fstrength-reduce and -finline-functions
-+# Unfortunately, strength-reduce triggers a bug in the gcc-2.95.2.
-+OPT_FLAGS:=-fno-strength-reduce -finline-functions ${CFLAGS}
-
- # Miscellaneous system libraries.
diff --git a/x11/xloadimage/files/patch-Makefile.in b/x11/xloadimage/files/patch-Makefile.in
new file mode 100644
index 000000000000..3370c79f5072
--- /dev/null
+++ b/x11/xloadimage/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Jun 6 23:49:17 2001
++++ Makefile.in Wed Jun 6 23:49:29 2001
+@@ -4,7 +4,7 @@
+
+ CC = @CC@
+ DEFS = @DEFS@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ @CPPFLAGS@ @X_CFLAGS@
+ XLIB = @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
diff --git a/x11/xloadimage/files/patch-xloadimage.man b/x11/xloadimage/files/patch-xloadimage.man
new file mode 100644
index 000000000000..f0e4cd6fe6dc
--- /dev/null
+++ b/x11/xloadimage/files/patch-xloadimage.man
@@ -0,0 +1,10 @@
+--- xloadimage.man.orig Thu Jun 7 00:15:57 2001
++++ xloadimage.man Thu Jun 7 00:20:11 2001
+@@ -633,7 +633,6 @@
+ xloadimage - the image loader and viewer
+ xsetbg - pseudonym which quietly sets the background
+ xview - pseudonym which views in a window
+-/etc/X11/Xloadimage - default system-wide configuration file
+ ~/.xloadimagerc - user's personal configuration file
+ .in -5
+ .fi
diff --git a/x11/xloadimage/pkg-descr b/x11/xloadimage/pkg-descr
index 96ee07c82790..f56df7e87c92 100644
--- a/x11/xloadimage/pkg-descr
+++ b/x11/xloadimage/pkg-descr
@@ -4,6 +4,7 @@ images onto the root window. The current version supports:
Sun Rasterfile
GIF Image
JFIF-style JPEG Image
+ Portabel Network Graphics (PNG)
TIFF image
FBM Image
CMU WM Raster
diff --git a/x11/xloadimage/pkg-plist b/x11/xloadimage/pkg-plist
index 84cfb8b4cb68..c826167d818c 100644
--- a/x11/xloadimage/pkg-plist
+++ b/x11/xloadimage/pkg-plist
@@ -1,3 +1,7 @@
+@comment $FreeBSD$
bin/uufilter
bin/xloadimage
-lib/X11/app-defaults/Xloadimage
+bin/xsetbg
+bin/xview
+share/examples/xloadimage/xloadimagerc
+@dirrm share/examples/xloadimage