aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-05 20:17:08 +0800
committerWill Andrews <will@FreeBSD.org>2001-03-05 20:17:08 +0800
commit34849535bebfc5c5d005eca7cd0f98a370f72b8f (patch)
treee128e75ec713570fee1d10d4741e8f3ee842bcd9 /x11
parent7f69652b20076b42f78d474a9b090aff3c2d59b2 (diff)
downloadfreebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.tar.gz
freebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.tar.zst
freebsd-ports-34849535bebfc5c5d005eca7cd0f98a370f72b8f.zip
Attempt to fix conflicts with a local getopt.h (specifically, the fix is
for libgnugetopt's getopt.h). Not tested, but should work.
Notes
Notes: svn path=/head/; revision=39086
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile2
-rw-r--r--x11/kde4-runtime/Makefile2
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kdebase2/Makefile2
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase4-runtime/Makefile2
-rw-r--r--x11/kdebase4-workspace/Makefile2
-rw-r--r--x11/kdebase4/Makefile2
-rw-r--r--x11/kdelibs2/Makefile2
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index a346796a21ee..4beb1235bc5f 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
--with-extra-libs=${LOCALBASE}/lib \
--disable-closure
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
USE_GMAKE= yes
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 44b695d2e414..5ba118d06462 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include -D_GETOPT_H" \
MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 44b695d2e414..5ba118d06462 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include -D_GETOPT_H" \
MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 44b695d2e414..5ba118d06462 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include -D_GETOPT_H" \
MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes