aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-gettext/Makefile35
-rw-r--r--devel/ruby-gettext/distinfo1
-rw-r--r--devel/ruby-gettext/pkg-comment1
-rw-r--r--devel/ruby-gettext/pkg-descr6
-rw-r--r--devel/ruby-gettext/pkg-plist39
-rw-r--r--devel/rubygem-gettext/Makefile35
-rw-r--r--devel/rubygem-gettext/distinfo1
-rw-r--r--devel/rubygem-gettext/pkg-comment1
-rw-r--r--devel/rubygem-gettext/pkg-descr6
-rw-r--r--devel/rubygem-gettext/pkg-plist39
-rw-r--r--devel/rubygem-locale/Makefile35
-rw-r--r--devel/rubygem-locale/distinfo1
-rw-r--r--devel/rubygem-locale/pkg-comment1
-rw-r--r--devel/rubygem-locale/pkg-descr6
-rw-r--r--devel/rubygem-locale/pkg-plist39
16 files changed, 247 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 08408bc587cc..1a49ef73a3c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -557,6 +557,7 @@
SUBDIR += ruby-fnmatch
SUBDIR += ruby-gconf
SUBDIR += ruby-gemfinder
+ SUBDIR += ruby-gettext
SUBDIR += ruby-gnustep
SUBDIR += ruby-intl
SUBDIR += ruby-lapidary
diff --git a/devel/ruby-gettext/Makefile b/devel/ruby-gettext/Makefile
new file mode 100644
index 000000000000..c11369f09f4a
--- /dev/null
+++ b/devel/ruby-gettext/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby GetText Package
+# Date created: 4 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gettext
+PORTVERSION= 0.1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://home2.highway.ne.jp/mutoh/tools/ruby/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+post-extract:
+ ${FIND} ${WRKSRC} -type d -name CVS -exec ${RM} -rf {} ';' -prune
+ ${FIND} ${WRKSRC} -type f -name '*~' -delete
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/docs/* ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-gettext/distinfo b/devel/ruby-gettext/distinfo
new file mode 100644
index 000000000000..8451a00b04b5
--- /dev/null
+++ b/devel/ruby-gettext/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-gettext-package-0.1.1.tar.gz) = 7434e7080a88979cf0b22e9726c1ef5b
diff --git a/devel/ruby-gettext/pkg-comment b/devel/ruby-gettext/pkg-comment
new file mode 100644
index 000000000000..31c1c4e4aeda
--- /dev/null
+++ b/devel/ruby-gettext/pkg-comment
@@ -0,0 +1 @@
+A Ruby implementation of the gettext library
diff --git a/devel/ruby-gettext/pkg-descr b/devel/ruby-gettext/pkg-descr
new file mode 100644
index 000000000000..da13dd469ece
--- /dev/null
+++ b/devel/ruby-gettext/pkg-descr
@@ -0,0 +1,6 @@
+Ruby GetText Package is Native Language Support Library and Tools
+which modeled after GNU GetText package, but the API is simpler than
+that of GNU GetText.
+
+Author: Masao Mutoh <mutoh@highway.ne.jp>
+WWW: http://home2.highway.ne.jp/mutoh/tools/ruby/en/ruby-gettext.html
diff --git a/devel/ruby-gettext/pkg-plist b/devel/ruby-gettext/pkg-plist
new file mode 100644
index 000000000000..5f4d9a70de94
--- /dev/null
+++ b/devel/ruby-gettext/pkg-plist
@@ -0,0 +1,39 @@
+bin/rgettext
+%%RUBY_SITELIBDIR%%/gettext.rb
+%%RUBY_SITELIBDIR%%/mo.rb
+share/locale/ja/LC_MESSAGES/rgettext.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hellogtk.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello2.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hellogtk.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello2.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hellogtk.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello2.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hellogtk.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/makemo.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/config.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/style.css
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/yard2html.rb
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext
diff --git a/devel/rubygem-gettext/Makefile b/devel/rubygem-gettext/Makefile
new file mode 100644
index 000000000000..c11369f09f4a
--- /dev/null
+++ b/devel/rubygem-gettext/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby GetText Package
+# Date created: 4 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gettext
+PORTVERSION= 0.1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://home2.highway.ne.jp/mutoh/tools/ruby/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+post-extract:
+ ${FIND} ${WRKSRC} -type d -name CVS -exec ${RM} -rf {} ';' -prune
+ ${FIND} ${WRKSRC} -type f -name '*~' -delete
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/docs/* ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gettext/distinfo b/devel/rubygem-gettext/distinfo
new file mode 100644
index 000000000000..8451a00b04b5
--- /dev/null
+++ b/devel/rubygem-gettext/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-gettext-package-0.1.1.tar.gz) = 7434e7080a88979cf0b22e9726c1ef5b
diff --git a/devel/rubygem-gettext/pkg-comment b/devel/rubygem-gettext/pkg-comment
new file mode 100644
index 000000000000..31c1c4e4aeda
--- /dev/null
+++ b/devel/rubygem-gettext/pkg-comment
@@ -0,0 +1 @@
+A Ruby implementation of the gettext library
diff --git a/devel/rubygem-gettext/pkg-descr b/devel/rubygem-gettext/pkg-descr
new file mode 100644
index 000000000000..da13dd469ece
--- /dev/null
+++ b/devel/rubygem-gettext/pkg-descr
@@ -0,0 +1,6 @@
+Ruby GetText Package is Native Language Support Library and Tools
+which modeled after GNU GetText package, but the API is simpler than
+that of GNU GetText.
+
+Author: Masao Mutoh <mutoh@highway.ne.jp>
+WWW: http://home2.highway.ne.jp/mutoh/tools/ruby/en/ruby-gettext.html
diff --git a/devel/rubygem-gettext/pkg-plist b/devel/rubygem-gettext/pkg-plist
new file mode 100644
index 000000000000..5f4d9a70de94
--- /dev/null
+++ b/devel/rubygem-gettext/pkg-plist
@@ -0,0 +1,39 @@
+bin/rgettext
+%%RUBY_SITELIBDIR%%/gettext.rb
+%%RUBY_SITELIBDIR%%/mo.rb
+share/locale/ja/LC_MESSAGES/rgettext.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hellogtk.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello2.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hellogtk.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello2.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hellogtk.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello2.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hellogtk.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/makemo.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/config.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/style.css
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/yard2html.rb
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext
diff --git a/devel/rubygem-locale/Makefile b/devel/rubygem-locale/Makefile
new file mode 100644
index 000000000000..c11369f09f4a
--- /dev/null
+++ b/devel/rubygem-locale/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby GetText Package
+# Date created: 4 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gettext
+PORTVERSION= 0.1.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://home2.highway.ne.jp/mutoh/tools/ruby/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+post-extract:
+ ${FIND} ${WRKSRC} -type d -name CVS -exec ${RM} -rf {} ';' -prune
+ ${FIND} ${WRKSRC} -type f -name '*~' -delete
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/samples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/docs/* ${RUBY_DOCDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-locale/distinfo b/devel/rubygem-locale/distinfo
new file mode 100644
index 000000000000..8451a00b04b5
--- /dev/null
+++ b/devel/rubygem-locale/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-gettext-package-0.1.1.tar.gz) = 7434e7080a88979cf0b22e9726c1ef5b
diff --git a/devel/rubygem-locale/pkg-comment b/devel/rubygem-locale/pkg-comment
new file mode 100644
index 000000000000..31c1c4e4aeda
--- /dev/null
+++ b/devel/rubygem-locale/pkg-comment
@@ -0,0 +1 @@
+A Ruby implementation of the gettext library
diff --git a/devel/rubygem-locale/pkg-descr b/devel/rubygem-locale/pkg-descr
new file mode 100644
index 000000000000..da13dd469ece
--- /dev/null
+++ b/devel/rubygem-locale/pkg-descr
@@ -0,0 +1,6 @@
+Ruby GetText Package is Native Language Support Library and Tools
+which modeled after GNU GetText package, but the API is simpler than
+that of GNU GetText.
+
+Author: Masao Mutoh <mutoh@highway.ne.jp>
+WWW: http://home2.highway.ne.jp/mutoh/tools/ruby/en/ruby-gettext.html
diff --git a/devel/rubygem-locale/pkg-plist b/devel/rubygem-locale/pkg-plist
new file mode 100644
index 000000000000..5f4d9a70de94
--- /dev/null
+++ b/devel/rubygem-locale/pkg-plist
@@ -0,0 +1,39 @@
+bin/rgettext
+%%RUBY_SITELIBDIR%%/gettext.rb
+%%RUBY_SITELIBDIR%%/mo.rb
+share/locale/ja/LC_MESSAGES/rgettext.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hello2.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/hellogtk.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hello2.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES/hellogtk.mo
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hello2.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/hellogtk.pot
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hello2.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/ja/hellogtk.po
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/gettext/po/makemo.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/po
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja/LC_MESSAGES
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale/ja
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/gettext/locale
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/config.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/en/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/ja/ruby-gettext.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/html/style.css
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/en/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/LANGUAGE
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/rd/ja/ruby-gettext.rd
+%%PORTDOCS%%%%RUBY_DOCDIR%%/gettext/yard2html.rb
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html/en
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext/html
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/gettext