aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/xcpc/Makefile62
-rw-r--r--emulators/xcpc/distinfo3
-rw-r--r--emulators/xcpc/pkg-descr17
-rw-r--r--emulators/xcpc/pkg-plist10
5 files changed, 93 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 8b397c11b07f..cdc79e774f37 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -188,6 +188,7 @@
SUBDIR += wine-doors
SUBDIR += x48
SUBDIR += xbraitenberg
+ SUBDIR += xcpc
SUBDIR += xgngeo
SUBDIR += xgs
SUBDIR += xhomer
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
new file mode 100644
index 000000000000..80f2d4bc9a0d
--- /dev/null
+++ b/emulators/xcpc/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: cpmtools
+# Date created: 31 January 2008
+# Whom: joerg
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcpc
+PORTVERSION= 20070122
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= pixel@hugbox.org
+COMMENT= A portable Amstrad 464&/664/6128 emulator
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+
+USE_XORG= ice
+USE_GNOME= pkgconfig glib20
+USE_ICONV= yes
+USE_GETTEXT= yes
+
+LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
+ pcre.0:${PORTSDIR}/devel/pcre \
+ dsk.5:${PORTSDIR}/emulators/libdsk
+
+OPTIONS= MOTIF "With Motif widget set" on \
+ ATHENA "With Athen widget set" off \
+ XSHM "With XShm support" on \
+ DEBUG "Turn debugging on" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--disable-debug
+.endif
+
+.if defined(WITH_XSHM)
+CONFIGURE_ARGS+=--enable-xshm
+.else
+CONFIGURE_ARGS+=--disable-xshm
+.endif
+
+.if defined(WITH_MOTIF)
+USE_MOTIF=yes
+CONFIGURE_ARGS+=--with-motif1
+.else
+CONFIGURE_ARGS+=--without-motif1
+.endif
+
+.if defined(WITH_ATHENA)
+LIB_DEPENDS+= Xaw.8:${PORTSDIR}/x11-toolkits/libXaw
+CONFIGURE_ARGS+=--with-athena
+.else
+CONFIGURE_ARGS+=--without-athena
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/xcpc/distinfo b/emulators/xcpc/distinfo
new file mode 100644
index 000000000000..b7ff63af0978
--- /dev/null
+++ b/emulators/xcpc/distinfo
@@ -0,0 +1,3 @@
+MD5 (xcpc-20070122.tar.gz) = 6b9d1c94b37e1cc10312dd46bd0696b7
+SHA256 (xcpc-20070122.tar.gz) = f63899248cb665375850855b9f3b201fe052f88f0883f75aa4d9fbef2b5cba43
+SIZE (xcpc-20070122.tar.gz) = 496627
diff --git a/emulators/xcpc/pkg-descr b/emulators/xcpc/pkg-descr
new file mode 100644
index 000000000000..bc0a6867d3de
--- /dev/null
+++ b/emulators/xcpc/pkg-descr
@@ -0,0 +1,17 @@
+Xcpc is a portable Amstrad CPC464/CPC664/CPC6128 Emulator written in C.
+It is designed to run on any POSIX system (Linux/BSD/UNIX-like OSes).
+
+Implemented Features:
+
+ * Athena GUI (selected at compilation time)
+ * Motif* GUI (selected at compilation time)
+ * Floppy disk images support (*.dsk)
+ * Snapshot memory images support (*.sna)
+ * Drag and Drop support (*.dsk, *.sna)
+ * Keyboard emulation (QWERTY, AZERTY)
+ * Joystick emulation (numeric keypad, numlock disabled)
+ * Almost full CRTC-6845 / GateArray emulation
+ * Adaptative frame-rate
+
+Author: Olivier Poncet <ponceto@noos.fr>
+WWW: http://xcpc.sourceforge.net/
diff --git a/emulators/xcpc/pkg-plist b/emulators/xcpc/pkg-plist
new file mode 100644
index 000000000000..c27f551ead95
--- /dev/null
+++ b/emulators/xcpc/pkg-plist
@@ -0,0 +1,10 @@
+bin/xcpc
+share/applications/xcpc.desktop
+share/pixmaps/xcpc.xpm
+%%DATADIR%%/roms/amsdos.rom
+%%DATADIR%%/roms/cpc464.rom
+%%DATADIR%%/roms/cpc6128.rom
+%%DATADIR%%/roms/cpc664.rom
+@dirrm %%DATADIR%%/roms
+@dirrm %%DATADIR%%
+@dirrmtry share/applications