aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/vmware2/Makefile4
-rw-r--r--emulators/vmware3/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 95615e57bada..5dffbb8ab8f7 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -93,6 +93,10 @@ post-patch:
${PERL} -i -pe 's,i386(/linux/linux_ioctl\.h),compat$$1,' \
${WRKSRC}/vmnet-only/freebsd/vmnet_linux.c
.endif
+.if exists(/usr/include/sys/selinfo.h)
+ ${PERL} -i -pe 's,<sys/select\.h>,<sys/selinfo.h>,' \
+ ${WRKSRC}/vmmon-only/freebsd/*.c
+.endif
setoptions:
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 95615e57bada..5dffbb8ab8f7 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -93,6 +93,10 @@ post-patch:
${PERL} -i -pe 's,i386(/linux/linux_ioctl\.h),compat$$1,' \
${WRKSRC}/vmnet-only/freebsd/vmnet_linux.c
.endif
+.if exists(/usr/include/sys/selinfo.h)
+ ${PERL} -i -pe 's,<sys/select\.h>,<sys/selinfo.h>,' \
+ ${WRKSRC}/vmmon-only/freebsd/*.c
+.endif
setoptions:
${SED} -e 's;@@PREFIX@@;${PREFIX};' \