aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/ranpwd/Makefile25
-rw-r--r--security/ranpwd/distinfo3
-rw-r--r--security/ranpwd/pkg-descr9
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d6a4b956e806..8a1671cbe122 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -690,6 +690,7 @@
SUBDIR += radiusniff
SUBDIR += rain
SUBDIR += rainbowcrack
+ SUBDIR += ranpwd
SUBDIR += rarcrack
SUBDIR += ratproxy
SUBDIR += rats
diff --git a/security/ranpwd/Makefile b/security/ranpwd/Makefile
new file mode 100644
index 000000000000..a5051b30024a
--- /dev/null
+++ b/security/ranpwd/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: ranpwd
+# Date created: Jun 11, 2009
+# Whom: corky1951@comcast.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= ranpwd
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_KERNEL_ORG}
+MASTER_SITE_SUBDIR= software/utils/admin/ranpwd
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= A tool to generate random passwords
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/ranpwd
+
+MAN1= ranpwd.1
+
+.include <bsd.port.mk>
diff --git a/security/ranpwd/distinfo b/security/ranpwd/distinfo
new file mode 100644
index 000000000000..74aa0bbab212
--- /dev/null
+++ b/security/ranpwd/distinfo
@@ -0,0 +1,3 @@
+MD5 (ranpwd-1.2.tar.gz) = 7f69760a48e9b2e36dd52c4769c470b5
+SHA256 (ranpwd-1.2.tar.gz) = b63cc1a621966a3bfabc83803c32617ef8caf5b7687042ac1b0eee04b8b79507
+SIZE (ranpwd-1.2.tar.gz) = 41018
diff --git a/security/ranpwd/pkg-descr b/security/ranpwd/pkg-descr
new file mode 100644
index 000000000000..1acdbc6f9b54
--- /dev/null
+++ b/security/ranpwd/pkg-descr
@@ -0,0 +1,9 @@
+ranpwd uses /dev/random or /dev/urandom to generate cryptographically secure
+passwords.
+
+Generated passwords may consist of any specified length and any combination of
+upper- or lower-case alphanumeric characters or punctuation. ranpwd can also
+generate passwords consisting of hexadecimal, decimal, octal or binary numbers,
+and format these as valid C constants for inclusion in source code.
+
+WWW: http://freshmeat.net/projects/ranpwd