aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 03c833171595..f42ea4f51e65 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.159 1995/05/12 07:43:48 asami Exp $
+# $Id: bsd.port.mk,v 1.160 1995/05/12 08:44:12 asami Exp $
#
# Please view me with 4 column tabs!
@@ -244,6 +244,12 @@ MTREE_LOCAL= /etc/mtree/BSD.local.dist
MTREE_CMD?= mtree
MTREE_ARGS?= -U -f ${MTREE_LOCAL} -d -e -p
+# The user can override the NO_PACKAGE by specifying this from
+# the make command line
+.if defined(FORCE_PACKAGE)
+.undef NO_PACKAGE
+.endif
+
PKG_CMD?= pkg_create
.if !defined(PKG_ARGS)
PKG_ARGS= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST -p ${PREFIX} -P "`${MAKE} package-depends|sort|uniq`"