aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/gimageview/Makefile7
-rw-r--r--mail/claws-mail/Makefile6
-rw-r--r--mail/gkrellmmailwatch/Makefile2
-rw-r--r--mail/sylpheed-claws/Makefile6
-rw-r--r--mail/sylpheed/Makefile6
-rw-r--r--mail/sylpheed2-devel/Makefile6
-rw-r--r--mail/sylpheed2/Makefile6
-rw-r--r--mail/sylpheed3/Makefile6
-rw-r--r--misc/gkrellmfmonitor/Makefile2
-rw-r--r--x11-wm/wmakerconf/Makefile2
10 files changed, 24 insertions, 25 deletions
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index b757f140fd1b..0bfd84d71662 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -14,12 +14,10 @@ MASTER_SITE_SUBDIR= gtkmmviewer
MAINTAINER= katsu@iec.hiroshima-u.ac.jp
COMMENT= Yet another GTK+ based image viewer
-LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
-
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
+USE_GNOME= gdkpixbuf
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -30,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if ${HAVE_GNOME:Mimlib}!=""
USE_GNOME+= imlib
PKGNAMESUFFIX= -imlib
+WITH_IMLIB= yes
.endif
post-patch:
@@ -37,7 +36,7 @@ post-patch:
${WRKSRC}/configure
post-configure:
-.if !defined(USE_IMLIB)
+.if !defined(WITH_IMLIB)
@${FIND} ${WRKSRC} -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} -Ee \
's/^(GDK_IMLIB_(CFLAGS|LIBS) =).*$$/$${1}/'
.endif
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index be57aa459d64..980ec750e2c4 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -27,7 +27,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_REINPLACE= yes
MAN1= sylpheed-claws.1
@@ -38,10 +38,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if defined(WITH_PIXBUF) || defined(WITH_ALL)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+= --disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+= --disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
diff --git a/mail/gkrellmmailwatch/Makefile b/mail/gkrellmmailwatch/Makefile
index cb0bbda2388b..22439c27a437 100644
--- a/mail/gkrellmmailwatch/Makefile
+++ b/mail/gkrellmmailwatch/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOME= imlib
do-install:
${MKDIR} ${PREFIX}/libexec/gkrellm/plugins
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index be57aa459d64..980ec750e2c4 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -27,7 +27,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_REINPLACE= yes
MAN1= sylpheed-claws.1
@@ -38,10 +38,10 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if defined(WITH_PIXBUF) || defined(WITH_ALL)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+= --disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+= --disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 6efad9399509..3cecca81450a 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -17,7 +17,7 @@ COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -29,10 +29,10 @@ CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
.include <bsd.port.pre.mk>
.if defined(WITH_PIXBUF)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+=--disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 6efad9399509..3cecca81450a 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -17,7 +17,7 @@ COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -29,10 +29,10 @@ CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
.include <bsd.port.pre.mk>
.if defined(WITH_PIXBUF)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+=--disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 6efad9399509..3cecca81450a 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -17,7 +17,7 @@ COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -29,10 +29,10 @@ CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
.include <bsd.port.pre.mk>
.if defined(WITH_PIXBUF)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+=--disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 6efad9399509..3cecca81450a 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -17,7 +17,7 @@ COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -29,10 +29,10 @@ CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
.include <bsd.port.pre.mk>
.if defined(WITH_PIXBUF)
-LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_GNOME+= gdkpixbuf
CONFIGURE_ARGS+=--disable-imlib
.else
-USE_IMLIB= yes
+USE_GNOME+= imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
diff --git a/misc/gkrellmfmonitor/Makefile b/misc/gkrellmfmonitor/Makefile
index 01153968e297..60ca20c665fc 100644
--- a/misc/gkrellmfmonitor/Makefile
+++ b/misc/gkrellmfmonitor/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
-USE_IMLIB= yes
+USE_GNOME= imlib
do-install:
${MKDIR} ${PREFIX}/libexec/gkrellm/plugins
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index 5b22f46e7a99..83ddfb3c3e4e 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -28,7 +28,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_XPM= yes
-USE_IMLIB= yes
+USE_GNOME= imlib
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wmakerdir="${X11BASE}/share/WindowMaker"