aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/sylpheed/Makefile9
-rw-r--r--mail/sylpheed/pkg-plist2
-rw-r--r--mail/sylpheed2-devel/Makefile9
-rw-r--r--mail/sylpheed2-devel/pkg-plist2
-rw-r--r--mail/sylpheed2/Makefile9
-rw-r--r--mail/sylpheed2/pkg-plist2
-rw-r--r--mail/sylpheed3/Makefile9
-rw-r--r--mail/sylpheed3/pkg-plist2
8 files changed, 28 insertions, 16 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 511ba6294f90..06bf2c9741f9 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -16,6 +16,9 @@ MASTER_SITE_SUBDIR= sylpheed-claws
MAINTAINER= oliver@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,7 +28,9 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
+CONFIGURE_ARGS= --enable-ipv6 \
+ --prefix=${PREFIX} \
+ --with-libintl-prefix=${LOCALBASE} \
--program-transform-name=''
.if !defined(WITHOUT_SSL)
@@ -76,7 +81,7 @@ CONFIGURE_ARGS+=--enable-ssl
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
-
+
MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
diff --git a/mail/sylpheed/pkg-plist b/mail/sylpheed/pkg-plist
index cdfb222d8acc..b331d590a00c 100644
--- a/mail/sylpheed/pkg-plist
+++ b/mail/sylpheed/pkg-plist
@@ -1,5 +1,4 @@
bin/sylpheed
-lib/charset.alias
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.jp
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
@@ -21,7 +20,6 @@ share/locale/hu/LC_MESSAGES/sylpheed.mo
share/locale/it/LC_MESSAGES/sylpheed.mo
share/locale/ja/LC_MESSAGES/sylpheed.mo
share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/locale.alias
share/locale/nl/LC_MESSAGES/sylpheed.mo
share/locale/pl/LC_MESSAGES/sylpheed.mo
share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 511ba6294f90..06bf2c9741f9 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -16,6 +16,9 @@ MASTER_SITE_SUBDIR= sylpheed-claws
MAINTAINER= oliver@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,7 +28,9 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
+CONFIGURE_ARGS= --enable-ipv6 \
+ --prefix=${PREFIX} \
+ --with-libintl-prefix=${LOCALBASE} \
--program-transform-name=''
.if !defined(WITHOUT_SSL)
@@ -76,7 +81,7 @@ CONFIGURE_ARGS+=--enable-ssl
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
-
+
MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
diff --git a/mail/sylpheed2-devel/pkg-plist b/mail/sylpheed2-devel/pkg-plist
index cdfb222d8acc..b331d590a00c 100644
--- a/mail/sylpheed2-devel/pkg-plist
+++ b/mail/sylpheed2-devel/pkg-plist
@@ -1,5 +1,4 @@
bin/sylpheed
-lib/charset.alias
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.jp
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
@@ -21,7 +20,6 @@ share/locale/hu/LC_MESSAGES/sylpheed.mo
share/locale/it/LC_MESSAGES/sylpheed.mo
share/locale/ja/LC_MESSAGES/sylpheed.mo
share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/locale.alias
share/locale/nl/LC_MESSAGES/sylpheed.mo
share/locale/pl/LC_MESSAGES/sylpheed.mo
share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 511ba6294f90..06bf2c9741f9 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -16,6 +16,9 @@ MASTER_SITE_SUBDIR= sylpheed-claws
MAINTAINER= oliver@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,7 +28,9 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
+CONFIGURE_ARGS= --enable-ipv6 \
+ --prefix=${PREFIX} \
+ --with-libintl-prefix=${LOCALBASE} \
--program-transform-name=''
.if !defined(WITHOUT_SSL)
@@ -76,7 +81,7 @@ CONFIGURE_ARGS+=--enable-ssl
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
-
+
MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
diff --git a/mail/sylpheed2/pkg-plist b/mail/sylpheed2/pkg-plist
index cdfb222d8acc..b331d590a00c 100644
--- a/mail/sylpheed2/pkg-plist
+++ b/mail/sylpheed2/pkg-plist
@@ -1,5 +1,4 @@
bin/sylpheed
-lib/charset.alias
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.jp
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
@@ -21,7 +20,6 @@ share/locale/hu/LC_MESSAGES/sylpheed.mo
share/locale/it/LC_MESSAGES/sylpheed.mo
share/locale/ja/LC_MESSAGES/sylpheed.mo
share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/locale.alias
share/locale/nl/LC_MESSAGES/sylpheed.mo
share/locale/pl/LC_MESSAGES/sylpheed.mo
share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 511ba6294f90..06bf2c9741f9 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -16,6 +16,9 @@ MASTER_SITE_SUBDIR= sylpheed-claws
MAINTAINER= oliver@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,7 +28,9 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext \
+CONFIGURE_ARGS= --enable-ipv6 \
+ --prefix=${PREFIX} \
+ --with-libintl-prefix=${LOCALBASE} \
--program-transform-name=''
.if !defined(WITHOUT_SSL)
@@ -76,7 +81,7 @@ CONFIGURE_ARGS+=--enable-ssl
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
-
+
MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
diff --git a/mail/sylpheed3/pkg-plist b/mail/sylpheed3/pkg-plist
index cdfb222d8acc..b331d590a00c 100644
--- a/mail/sylpheed3/pkg-plist
+++ b/mail/sylpheed3/pkg-plist
@@ -1,5 +1,4 @@
bin/sylpheed
-lib/charset.alias
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.jp
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
@@ -21,7 +20,6 @@ share/locale/hu/LC_MESSAGES/sylpheed.mo
share/locale/it/LC_MESSAGES/sylpheed.mo
share/locale/ja/LC_MESSAGES/sylpheed.mo
share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/locale.alias
share/locale/nl/LC_MESSAGES/sylpheed.mo
share/locale/pl/LC_MESSAGES/sylpheed.mo
share/locale/pt_BR/LC_MESSAGES/sylpheed.mo