aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/rxvt-devel/Makefile5
-rw-r--r--x11/rxvt-unicode/Makefile1
-rw-r--r--x11/rxvt-unicode/files/patch-ad13
-rw-r--r--x11/rxvt/Makefile1
-rw-r--r--x11/rxvt/files/patch-ad13
5 files changed, 29 insertions, 4 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index 5d4ff734f725..03a0e5470ed1 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -10,6 +10,7 @@
PORTNAME= rxvt
PORTVERSION= 2.7.8
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
ftp://mason.primenet.com.au/pub/rxvt/%SUBDIR%/ \
@@ -120,6 +121,10 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${PERL} -pi -e 's|(PTYCHAR2\s+"[^"]+)"|\1ghijklmnopqrstuv"|' \
+ ${WRKSRC}/src/ptytty.c
+
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/rxvt
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index b219ca38160d..bace02560487 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -10,6 +10,7 @@
PORTNAME= rxvt
PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES+= x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
ftp://mason.primenet.com.au/pub/rxvt/%SUBDIR%/ \
diff --git a/x11/rxvt-unicode/files/patch-ad b/x11/rxvt-unicode/files/patch-ad
index 6f3e7e9a7bcb..c057993b80dc 100644
--- a/x11/rxvt-unicode/files/patch-ad
+++ b/x11/rxvt-unicode/files/patch-ad
@@ -1,11 +1,20 @@
--- src/command.c.orig Thu Apr 5 03:52:39 2001
+++ src/command.c Fri Jun 22 13:36:57 2001
-@@ -2796,7 +2796,7 @@ rxvt_tt_printf(rxvt_t *r, const char *fm
+@@ -322,7 +322,7 @@
+ ttydev = tty_name;
+
+ # define PTYCHAR1 "pqrstuvwxyz"
+-# define PTYCHAR2 "0123456789abcdef"
++# define PTYCHAR2 "0123456789abcdefghijklmnopqrstuv"
+ for (c1 = PTYCHAR1; *c1; c1++) {
+ ptydev[len] = ttydev[len] = *c1;
+ for (c2 = PTYCHAR2; *c2; c2++) {
+@@ -2376,7 +2376,7 @@
unsigned char buf[256];
va_start(arg_ptr, fmt);
- vsprintf(buf, fmt, arg_ptr);
+ vsnprintf(buf, sizeof(buf), fmt, arg_ptr);
va_end(arg_ptr);
- rxvt_tt_write(r, buf, STRLEN(buf));
+ tt_write(buf, strlen(buf));
}
diff --git a/x11/rxvt/Makefile b/x11/rxvt/Makefile
index b219ca38160d..bace02560487 100644
--- a/x11/rxvt/Makefile
+++ b/x11/rxvt/Makefile
@@ -10,6 +10,7 @@
PORTNAME= rxvt
PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES+= x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
ftp://mason.primenet.com.au/pub/rxvt/%SUBDIR%/ \
diff --git a/x11/rxvt/files/patch-ad b/x11/rxvt/files/patch-ad
index 6f3e7e9a7bcb..c057993b80dc 100644
--- a/x11/rxvt/files/patch-ad
+++ b/x11/rxvt/files/patch-ad
@@ -1,11 +1,20 @@
--- src/command.c.orig Thu Apr 5 03:52:39 2001
+++ src/command.c Fri Jun 22 13:36:57 2001
-@@ -2796,7 +2796,7 @@ rxvt_tt_printf(rxvt_t *r, const char *fm
+@@ -322,7 +322,7 @@
+ ttydev = tty_name;
+
+ # define PTYCHAR1 "pqrstuvwxyz"
+-# define PTYCHAR2 "0123456789abcdef"
++# define PTYCHAR2 "0123456789abcdefghijklmnopqrstuv"
+ for (c1 = PTYCHAR1; *c1; c1++) {
+ ptydev[len] = ttydev[len] = *c1;
+ for (c2 = PTYCHAR2; *c2; c2++) {
+@@ -2376,7 +2376,7 @@
unsigned char buf[256];
va_start(arg_ptr, fmt);
- vsprintf(buf, fmt, arg_ptr);
+ vsnprintf(buf, sizeof(buf), fmt, arg_ptr);
va_end(arg_ptr);
- rxvt_tt_write(r, buf, STRLEN(buf));
+ tt_write(buf, strlen(buf));
}