aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/p5-Tie-DNS/Makefile33
-rw-r--r--dns/p5-Tie-DNS/distinfo1
-rw-r--r--dns/p5-Tie-DNS/pkg-comment1
-rw-r--r--dns/p5-Tie-DNS/pkg-descr8
-rw-r--r--dns/p5-Tie-DNS/pkg-plist13
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Tie-DNS/Makefile33
-rw-r--r--net/p5-Tie-DNS/distinfo1
-rw-r--r--net/p5-Tie-DNS/pkg-comment1
-rw-r--r--net/p5-Tie-DNS/pkg-descr8
-rw-r--r--net/p5-Tie-DNS/pkg-plist13
11 files changed, 113 insertions, 0 deletions
diff --git a/dns/p5-Tie-DNS/Makefile b/dns/p5-Tie-DNS/Makefile
new file mode 100644
index 000000000000..d01865bedb54
--- /dev/null
+++ b/dns/p5-Tie-DNS/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Tie::DNS
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-DNS
+PORTVERSION= 0.41
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+PERL_CONFIGURE= yes
+
+MAN3= Tie::DNS.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/eg/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Tie-DNS/distinfo b/dns/p5-Tie-DNS/distinfo
new file mode 100644
index 000000000000..cdf0fda820e4
--- /dev/null
+++ b/dns/p5-Tie-DNS/distinfo
@@ -0,0 +1 @@
+MD5 (Tie-DNS-0.41.tar.gz) = 234d5840bc9652155db9a9d90140984c
diff --git a/dns/p5-Tie-DNS/pkg-comment b/dns/p5-Tie-DNS/pkg-comment
new file mode 100644
index 000000000000..9aa7d38d54fd
--- /dev/null
+++ b/dns/p5-Tie-DNS/pkg-comment
@@ -0,0 +1 @@
+Tie interface to p5-Net-DNS
diff --git a/dns/p5-Tie-DNS/pkg-descr b/dns/p5-Tie-DNS/pkg-descr
new file mode 100644
index 000000000000..c13a1ae07a8f
--- /dev/null
+++ b/dns/p5-Tie-DNS/pkg-descr
@@ -0,0 +1,8 @@
+This module is meant to be a simplified interface to the
+excellent Net::DNS module. Its goal is to make operations
+that are easy in Net::DNS trivial, and operations that are
+hard in Net::DNS easy.
+
+WWW: http://search.cpan.org/search?dist=Tie-DNS
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/dns/p5-Tie-DNS/pkg-plist b/dns/p5-Tie-DNS/pkg-plist
new file mode 100644
index 000000000000..73a186a3ba63
--- /dev/null
+++ b/dns/p5-Tie-DNS/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DNS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Tie/DNS.pm
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example1.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example2.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example3.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example4.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example5.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example6.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example7.pl
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Tie 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DNS 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie 2>/dev/null || true
+%%PORTDOCS%%@unexec rmdir %D/share/examples/p5-Tie-DNS 2>/dev/null || true
diff --git a/net/Makefile b/net/Makefile
index a01ce077e8a1..07204c3f63db 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -381,6 +381,7 @@
SUBDIR += p5-Socks
SUBDIR += p5-Spread-Session
SUBDIR += p5-Telnet-Cisco
+ SUBDIR += p5-Tie-DNS
SUBDIR += p5-Tie-NetAddr-IP
SUBDIR += p5-URI
SUBDIR += p5-XPC
diff --git a/net/p5-Tie-DNS/Makefile b/net/p5-Tie-DNS/Makefile
new file mode 100644
index 000000000000..d01865bedb54
--- /dev/null
+++ b/net/p5-Tie-DNS/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Tie::DNS
+# Date created: 25 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-DNS
+PORTVERSION= 0.41
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+PERL_CONFIGURE= yes
+
+MAN3= Tie::DNS.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/eg/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/p5-Tie-DNS/distinfo b/net/p5-Tie-DNS/distinfo
new file mode 100644
index 000000000000..cdf0fda820e4
--- /dev/null
+++ b/net/p5-Tie-DNS/distinfo
@@ -0,0 +1 @@
+MD5 (Tie-DNS-0.41.tar.gz) = 234d5840bc9652155db9a9d90140984c
diff --git a/net/p5-Tie-DNS/pkg-comment b/net/p5-Tie-DNS/pkg-comment
new file mode 100644
index 000000000000..9aa7d38d54fd
--- /dev/null
+++ b/net/p5-Tie-DNS/pkg-comment
@@ -0,0 +1 @@
+Tie interface to p5-Net-DNS
diff --git a/net/p5-Tie-DNS/pkg-descr b/net/p5-Tie-DNS/pkg-descr
new file mode 100644
index 000000000000..c13a1ae07a8f
--- /dev/null
+++ b/net/p5-Tie-DNS/pkg-descr
@@ -0,0 +1,8 @@
+This module is meant to be a simplified interface to the
+excellent Net::DNS module. Its goal is to make operations
+that are easy in Net::DNS trivial, and operations that are
+hard in Net::DNS easy.
+
+WWW: http://search.cpan.org/search?dist=Tie-DNS
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/net/p5-Tie-DNS/pkg-plist b/net/p5-Tie-DNS/pkg-plist
new file mode 100644
index 000000000000..73a186a3ba63
--- /dev/null
+++ b/net/p5-Tie-DNS/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DNS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Tie/DNS.pm
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example1.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example2.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example3.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example4.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example5.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example6.pl
+%%PORTDOCS%%share/examples/p5-Tie-DNS/example7.pl
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Tie 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie/DNS 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Tie 2>/dev/null || true
+%%PORTDOCS%%@unexec rmdir %D/share/examples/p5-Tie-DNS 2>/dev/null || true