aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--news/tin/Makefile3
-rw-r--r--news/tin/distinfo2
-rw-r--r--news/tin/files/patch-ad11
-rw-r--r--news/tin/files/patch-ae10
4 files changed, 23 insertions, 3 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index c8285fcef79d..1e7c30f582ab 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tin
-PORTVERSION= 1.5.6
-PORTREVISION= 1
+PORTVERSION= 1.5.8
CATEGORIES= news
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v1.5/ \
ftp://nuxi.ucdavis.edu/pub/tin/v1.5/ \
diff --git a/news/tin/distinfo b/news/tin/distinfo
index b276b1347c67..f60a26ffb76e 100644
--- a/news/tin/distinfo
+++ b/news/tin/distinfo
@@ -1 +1 @@
-MD5 (tin-1.5.6.tar.bz2) = fe40834d4e8f6386a4199123cd67a5f3
+MD5 (tin-1.5.8.tar.bz2) = f970eef234a04d8a13547ae66d9867f2
diff --git a/news/tin/files/patch-ad b/news/tin/files/patch-ad
new file mode 100644
index 000000000000..8c92cb2d8215
--- /dev/null
+++ b/news/tin/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/keymap.c Thu Aug 3 13:26:37 2000
++++ src/keymap.c Sat Apr 14 00:12:27 2001
+@@ -916,6 +916,8 @@
+ snprintf(buff, sizeof(buf) - 1, "%s/.tin/keymap.%s", ptr2, map);
+ if (strfpath (buff, buf, sizeof(buf), &CURR_GROUP))
+ fp = fopen (buf, "r");
++ if (ptr)
++ *ptr = '.';
+ }
+ if (!fp) {
+ snprintf(buff, sizeof(buf) - 1, "%s/.tin/keymap", ptr2);
diff --git a/news/tin/files/patch-ae b/news/tin/files/patch-ae
new file mode 100644
index 000000000000..eacf58a2cc92
--- /dev/null
+++ b/news/tin/files/patch-ae
@@ -0,0 +1,10 @@
+--- include/autoconf.hin.bak Wed Jan 10 03:58:27 2001
++++ include/autoconf.hin Sat Apr 14 02:02:10 2001
+@@ -49,7 +49,6 @@
+
+ /* compiler, compilerflags, ... */
+ # undef TIN_CC
+-# undef TIN_CFLAGS
+ # undef TIN_CPP
+ # undef TIN_CPPFLAGS
+ # undef TIN_LD