aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gkrellkam/Makefile33
-rw-r--r--graphics/gkrellkam/distinfo1
-rw-r--r--graphics/gkrellkam/files/patch-Makefile16
-rw-r--r--graphics/gkrellkam/pkg-comment1
-rw-r--r--graphics/gkrellkam/pkg-descr7
-rw-r--r--graphics/gkrellkam/pkg-plist1
7 files changed, 60 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e8e234b34fd0..6b56849be02f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -67,6 +67,7 @@
SUBDIR += gimp-manual-ps
SUBDIR += gimp1
SUBDIR += giram
+ SUBDIR += gkrellkam
SUBDIR += glass
SUBDIR += gle
SUBDIR += glide3
diff --git a/graphics/gkrellkam/Makefile b/graphics/gkrellkam/Makefile
new file mode 100644
index 000000000000..3a8918159edd
--- /dev/null
+++ b/graphics/gkrellkam/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gkrellkam
+# Date Created: Fri Aug 17 15:57:42 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellkam
+PORTVERSION= 0.2.3b
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= pat@databits.net
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_IMLIB= yes
+USE_GMAKE= yes
+
+MAN5= gkrellkam-list.5
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gkrellkam.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+ @${INSTALL_MAN} ${WRKSRC}/gkrellkam-list.5 ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/graphics/gkrellkam/distinfo b/graphics/gkrellkam/distinfo
new file mode 100644
index 000000000000..4a26c38be7ec
--- /dev/null
+++ b/graphics/gkrellkam/distinfo
@@ -0,0 +1 @@
+MD5 (gkrellkam_0.2.3b.tar.gz) = c003dca178c14f13250663deb389d0de
diff --git a/graphics/gkrellkam/files/patch-Makefile b/graphics/gkrellkam/files/patch-Makefile
new file mode 100644
index 000000000000..d2db8f4cf9db
--- /dev/null
+++ b/graphics/gkrellkam/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig Tue Jul 31 19:27:40 2001
++++ Makefile Wed Aug 29 13:13:18 2001
+@@ -9,10 +9,9 @@
+ # To facilitate packaging- leave blank for normal installation
+ DESTDIR =
+
+-CC := gcc
+-GTKFLAGS := $(shell gtk-config --cflags)
+-IMLIBFLAGS := $(shell imlib-config --cflags-gdk)
+-CFLAGS := $(CFLAGS) -fPIC -Wall $(GTKFLAGS) $(IMLIBFLAGS)
++GTKFLAGS = `${GTK_CONFIG} --cflags`
++IMLIBFLAGS = `${IMLIB_CONFIG} --cflags-gdk`
++CFLAGS += -fPIC -Wall $(GTKFLAGS) $(IMLIBFLAGS)
+ LDFLAGS := -shared -Wl
+ INST_DIR := $(DESTDIR)/usr/lib/gkrellm/plugins
+ USER_INST_DIR := $(DESTDIR)$(HOME)/.gkrellm/plugins
diff --git a/graphics/gkrellkam/pkg-comment b/graphics/gkrellkam/pkg-comment
new file mode 100644
index 000000000000..7952655153bf
--- /dev/null
+++ b/graphics/gkrellkam/pkg-comment
@@ -0,0 +1 @@
+GKrellM plugin that display thumbnails of periodically updated images
diff --git a/graphics/gkrellkam/pkg-descr b/graphics/gkrellkam/pkg-descr
new file mode 100644
index 000000000000..308d4a71af72
--- /dev/null
+++ b/graphics/gkrellkam/pkg-descr
@@ -0,0 +1,7 @@
+A plugin to GKrellM that displays thumbnails of periodically updated
+images
+
+WWW: http://gkrellkam.sourceforge.net/
+Author: Paul Cannon <paul@cannon.cs.usu.edu>
+
+- Patrick Li <pat@databits.net>
diff --git a/graphics/gkrellkam/pkg-plist b/graphics/gkrellkam/pkg-plist
new file mode 100644
index 000000000000..ee841b5979b4
--- /dev/null
+++ b/graphics/gkrellkam/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm/plugins/gkrellkam.so