aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/w3mir/Makefile9
-rw-r--r--www/w3mir/pkg-plist3
2 files changed, 11 insertions, 1 deletions
diff --git a/www/w3mir/Makefile b/www/w3mir/Makefile
index 19d29fd348bc..ebb39616e371 100644
--- a/www/w3mir/Makefile
+++ b/www/w3mir/Makefile
@@ -4,7 +4,7 @@
# Date created: 9 May 1998
# Whom: ache
#
-# $Id: Makefile,v 1.1.1.1 1998/05/09 10:20:39 ache Exp $
+# $Id: Makefile,v 1.17 1998/04/28 14:45:37 vanilla Exp $
#
DISTNAME= w3mir-1.0.2
@@ -22,4 +22,11 @@ MAN1= w3mir.1 w3mfix.1
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+post-install:
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 \
+ ${PREFIX}/share/doc/w3mir
+ cd ${WRKSRC} && ${INSTALL_DATA} \
+ README Artistic w3mir-HOWTO.html \
+ ${PREFIX}/share/doc/w3mir
+
.include <bsd.port.mk>
diff --git a/www/w3mir/pkg-plist b/www/w3mir/pkg-plist
index 5d97f60590d1..c00e191678eb 100644
--- a/www/w3mir/pkg-plist
+++ b/www/w3mir/pkg-plist
@@ -5,3 +5,6 @@ man/man1/w3mir.1.gz
man/man1/w3mfix.1.gz
bin/w3mir
bin/w3mfix
+share/doc/w3mir/README
+share/doc/w3mir/Artistic
+share/doc/w3mir/w3mir-HOWTO.html
bbd06b8e826d9'>Remove this file, since it will now be generated entirely in theTrevor Johnson2002-03-041-3/+0 * Add new port of Netscape 6 (Linux binary) with German localization.Trevor Johnson2002-03-0410 class='alt'>
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40




                                                                          
                                                           

 
                 


                      
                                

                                       

                                                                  
                                                   






                                    
                                           

                                 
                            
 


                                   

                                                                            

                                                        
 
                                                 
                                
# New ports collection makefile for:        gmime2-sharp
# Date Created:                 20050513
# Whom:             Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
#   $Id: Makefile,v 1.17 2006/10/26 18:37:29 tmclau02 Exp $
#

PORTREVISION=   2
CATEGORIES= mail
PKGNAMESUFFIX=  -sharp

MAINTAINER= mono@FreeBSD.org
COMMENT=    Mono bindings for gmime

IGNORE=     try to install weaked-named assembly into the GAC.

LIB_DEPENDS=    gmime-2.0.4:${PORTSDIR}/mail/gmime2

MASTERDIR=  ${.CURDIR}/../gmime2
BUILD_WRKSRC=   ${WRKSRC}/mono
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR=      ${.CURDIR}/pkg-descr
PLIST=      ${.CURDIR}/pkg-plist

USE_GNOME=  gnomehack glib20 gtksharp20
CONFIGURE_ARGS= --enable-mono=yes

LATEST_LINK=    gmime2-sharp

# Else we conflict with mail/gmime2
NOPORTDOCS= yes

# Done in pre-configure because master port has a post-patch target already.
pre-configure:
    @${REINPLACE_CMD} -e 's|.@GMIME_VERSION@||g' \
        ${WRKSRC}/mono/gmime-sharp.dll.config.in

.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include "${MASTERDIR}/Makefile"