aboutsummaryrefslogtreecommitdiffstats
path: root/audio/p5-Net-FreeDB/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/p5-Net-FreeDB/Makefile')
-rw-r--r--audio/p5-Net-FreeDB/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/audio/p5-Net-FreeDB/Makefile b/audio/p5-Net-FreeDB/Makefile
index f966930227f8..4e5de60dfe31 100644
--- a/audio/p5-Net-FreeDB/Makefile
+++ b/audio/p5-Net-FreeDB/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-FreeDB
-PORTVERSION= 0.07
+PORTVERSION= 0.08
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROAM
@@ -16,7 +16,8 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Get the CDID of an audio CD and query the FreeDB servers
BUILD_DEPENDS= ${SITE_PERL}/CDDB/File.pm:${PORTSDIR}/audio/p5-CDDB-File \
- ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
+ ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,9 +26,9 @@ MAN3= Net::FreeDB.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600 # inherited by p5-Authen-SASL
+# devel/p5-File-Temp only works on Perl 5.6 or higher.
+.if ${PERL_LEVEL} < 500600
IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-#EXTRA_PATCHES+= ${FILESDIR}/perl-5005.patch
.endif
.include <bsd.port.post.mk>