aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/super-smack/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/super-smack/Makefile')
-rw-r--r--benchmarks/super-smack/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
new file mode 100644
index 000000000000..fe9a10f03d56
--- /dev/null
+++ b/benchmarks/super-smack/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: super-smack
+# Date created: 2005-12-10
+# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= super-smack
+PORTVERSION= 1.3
+CATEGORIES= benchmarks databases
+MASTER_SITES= http://vegan.net/tony/supersmack/
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+COMMENT= A benchmarking, stress testing, and load generation tool for Databases
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-smacks-dir=${DATADIR}
+
+OPTIONS= MYSQL "Enable MySQL support" on \
+ POSTGRESQL "Enable PostgreSQL support" off
+
+.if !defined(WITHOUT_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql
+.endif
+
+.if defined(WITH_POSTGRESQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-postgresql
+.endif
+
+.include <bsd.port.mk>