aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu/Makefile')
-rw-r--r--emulators/qemu/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d9cb1d2439c4..a3216aacc018 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -102,13 +102,16 @@ post-patch:
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile.target
@${REINPLACE_CMD} -E \
- -e "s,^(CFLAGS=).*,\1${CFLAGS} -fno-strict-aliasing -I.," \
- -e "s,^(LDFLAGS=).*,\1${LDFLAGS}," \
+ -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
+ -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E \
+ -e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
+ ${WRKSRC}/texi2pod.pl
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${PREFIX}/etc