aboutsummaryrefslogtreecommitdiffstats
path: root/irc/ctrlproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ctrlproxy/Makefile')
-rw-r--r--irc/ctrlproxy/Makefile18
1 files changed, 4 insertions, 14 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 694de066f5eb..85aafe2e989f 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -7,17 +7,16 @@
#
PORTNAME= ctrlproxy
-PORTVERSION= 2.6.1
-PORTREVISION= 2
+PORTVERSION= 2.6.2
CATEGORIES= irc
MASTER_SITES= http://jelmer.vernstok.nl/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Flexible IRC proxy
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+LIB_DEPENDS= tdb.1:${PORTSDIR}/databases/tdb \
pcre.0:${PORTSDIR}/devel/pcre \
- tdb.1:${PORTSDIR}/databases/tdb
+ popt.0:${PORTSDIR}/devel/popt
USE_OPENSSL= yes
USE_GNOME= glib20 libxml2
@@ -25,22 +24,13 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= ctrlproxy.1
-MAN5= ctrlproxyrc.5
-MAN7= admin.7ctrlproxy antiflood.7ctrlproxy auto-away.7ctrlproxy \
- ctcp.7ctrlproxy linestack_file.7ctrlproxy linestack_memory.7ctrlproxy \
- log_custom.7ctrlproxy log_irssi.7ctrlproxy motd-file.7ctrlproxy \
- nickserv.7ctrlproxy noticelog.7ctrlproxy repl_command.7ctrlproxy \
- repl_highlight.7ctrlproxy repl_none.7ctrlproxy repl_simple.7ctrlproxy \
- socket.7ctrlproxy stats.7ctrlproxy strip.7ctrlproxy
-
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
post-install:
.if !defined(NOPORTDOC)
@${MKDIR} ${DOCSDIR}
-.for file in AUTHORS TODO doc/ctrlproxy.html doc/ctrlproxy.pdf
+.for file in AUTHORS ChangeLog README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif