aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc42/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc42/Makefile')
-rw-r--r--lang/gcc42/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 042403edbbeb..1803f0d19ef9 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -16,10 +16,14 @@ MASTER_SITES= ftp://egcs.cygnus.com/pub/egcs/snapshots/1998-09-14/ \
MAINTAINER= obrien@FreeBSD.org
-BROKEN= package
-
EGCS_REV= egcs-2.92.07
LIBSTDCPP_REV= 2.9.0
+ARE_WE_ELF!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
+.if ${ARE_WE_ELF} == "elf"
+GNUHOST= i386-unknown-freebsdelf
+.else
+GNUHOST= i386-unknown-freebsd
+.endif
PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${GNUHOST}
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -69,9 +73,3 @@ post-install:
.endfor
.include <bsd.port.mk>
-
-.if (${PORTOBJFORMAT} == "elf")
-GNUHOST= i386-unknown-freebsdelf
-.else
-GNUHOST= i386-unknown-freebsd
-.endif