aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/demime/Makefile39
-rw-r--r--mail/demime/distinfo2
-rw-r--r--mail/demime/pkg-comment1
-rw-r--r--mail/demime/pkg-descr9
-rw-r--r--mail/demime/pkg-plist2
6 files changed, 54 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ad6f5d7e5ca1..b73d59f36a45 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -22,6 +22,7 @@
SUBDIR += cvsmail
SUBDIR += cyrus
SUBDIR += cyrus-imapd
+ SUBDIR += demime
SUBDIR += distribute
SUBDIR += drac
SUBDIR += elm
diff --git a/mail/demime/Makefile b/mail/demime/Makefile
new file mode 100644
index 000000000000..30050ef005c2
--- /dev/null
+++ b/mail/demime/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: demime
+# Date Created: 25 April 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= demime
+PORTVERSION= 0.98b
+CATEGORIES= mail textproc
+MASTER_SITES= http://scifi.squawk.com/
+DISTFILES= ${PORTNAME}.stable demime_junkmail.cf
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/FormatText.pm:${PORTSDIR}/textproc/p5-HTML-Format \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree
+
+NO_BUILD= yes
+
+USE_PERL5= yes
+POD2MAN?= /usr/bin/pod2man
+MAN1= demime.1
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/demime.stable ${WRKSRC}/demime
+
+post-patch:
+ @${PERL} -pi -e 's!/usr/lib/majordomo/demime_junkmail.cf!${PREFIX}/etc/demime_junkmail.cf!g' ${WRKSRC}/demime
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/demime ${PREFIX}/bin/demime
+ ${INSTALL_DATA} ${DISTDIR}/demime_junkmail.cf ${PREFIX}/etc
+ ${POD2MAN} ${WRKSRC}/demime > ${PREFIX}/man/man1/demime.1
+
+.include <bsd.port.mk>
diff --git a/mail/demime/distinfo b/mail/demime/distinfo
new file mode 100644
index 000000000000..0ee0366a942c
--- /dev/null
+++ b/mail/demime/distinfo
@@ -0,0 +1,2 @@
+MD5 (demime.stable) = 951acd055c203ed18dc373ab4bb50bfa
+MD5 (demime_junkmail.cf) = 1e0a379cbd5d9b11ec21b6d804cdef02
diff --git a/mail/demime/pkg-comment b/mail/demime/pkg-comment
new file mode 100644
index 000000000000..ef81cbbcd92b
--- /dev/null
+++ b/mail/demime/pkg-comment
@@ -0,0 +1 @@
+A tool to scrub mime from mailing lists
diff --git a/mail/demime/pkg-descr b/mail/demime/pkg-descr
new file mode 100644
index 000000000000..af99c962bb75
--- /dev/null
+++ b/mail/demime/pkg-descr
@@ -0,0 +1,9 @@
+A perl script to flatten some mime types to make mailing lists and
+archives more readable. This tool is designed to run with the
+Majordomo list manager, but can most likely be adapted to different
+list software.
+
+WWW: http://scifi.squawk.com/demime.html
+
+- Pete
+petef@databits.net
diff --git a/mail/demime/pkg-plist b/mail/demime/pkg-plist
new file mode 100644
index 000000000000..d6a3b61aa00d
--- /dev/null
+++ b/mail/demime/pkg-plist
@@ -0,0 +1,2 @@
+bin/demime
+etc/demime_junkmail.cf