aboutsummaryrefslogtreecommitdiffstats
path: root/math/gnuplot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/gnuplot/Makefile')
-rw-r--r--math/gnuplot/Makefile54
1 files changed, 41 insertions, 13 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 394e86086db5..90f07010b0bc 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnuplot
-PORTVERSION= 3.7.3
-PORTREVISION= 2
+PORTVERSION= 4.0.0
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,40 +14,69 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= glewis@FreeBSD.org
COMMENT= A command-driven interactive function plotting program
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --datadir=${DATADIR} \
- --without-linux-vga --without-gd \
- --with-readline=gnu --with-lasergnu
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-tutorial --without-linux-vga --without-gd \
+ --with-lasergnu
+
+OPTIONS= PNG "Enable PNG support" on \
+ PDF "Enable PDF support" on
MAN1= gnuplot.1 lasergnu.1
+INFO= gnuplot
+
+.if exists(${PREFIX}/bin/emacs) || exists(${PREFIX}/bin/xemacs)
+EMACS_PORT_NAME= emacs21
+EMACS_NO_BUILD_DEPENDS= yes
+EMACS_NO_RUN_DEPENDS= yes
+CONFIGURE_ARGS+= --with-lisp-files
+.else
+PLIST_SUB+= EMACS_SITE_LISPDIR="@comment "
+CONFIGURE_ARGS+= --without-lisp-files
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500018
+CONFIGURE_ARGS+= --with-readline=gnu
+.endif
.if !defined(WITHOUT_X11)
-USE_XLIB= yes
+USE_XLIB= yes
PLIST_SUB+= X11:=""
.else
CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11:="@comment "
.endif
-.if !defined(WITHOUT_PNG)
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-png
.endif
-.if !defined(WITHOUT_PDF)
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
+.if defined(WITH_PDF)
+LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-pdf
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/lasergnu ${PREFIX}/bin
+.if exists(${PREFIX}/bin/emacs) || exists(${PREFIX}/bin/xemacs)
+ ${INSTALL_DATA} ${WRKSRC}/lisp/gnuplot*.el ${EMACS_SITE_LISPDIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${FILESDIR}/README ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
+ cd ${WRKSRC}/demo && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>