aboutsummaryrefslogtreecommitdiffstats
path: root/math/py-numeric/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/py-numeric/files/patch-Makefile')
-rw-r--r--math/py-numeric/files/patch-Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/py-numeric/files/patch-Makefile b/math/py-numeric/files/patch-Makefile
new file mode 100644
index 000000000000..6512ba0c12ad
--- /dev/null
+++ b/math/py-numeric/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile 2000/08/31 17:23:34 1.1
++++ Makefile 2000/08/31 17:35:38
+@@ -5,8 +5,20 @@
+ @echo "Currently that is:"
+ @which python
+
+-all: MA RNG FFT
++all:: main MA RNG FFT
++
++main:
++ python setup.py build
+
+ MA RNG FFT:
+- (cd Packages/$@; python setup.py install)
++ (cd Packages/$@; mkdir -p Include ; ln -sf ../../../Include Include/Numeric; python setup.py build)
++
++install:: main_install MA_install RNG_install FFT_install
++
++main_install:
++ python setup.py install
++
++MA_install RNG_install FFT_install:
++ (cd Packages/${@:S/_install//}; python setup.py install)
++
+