aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/gnome-btdownload/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnome-btdownload/Makefile')
-rw-r--r--net-p2p/gnome-btdownload/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/net-p2p/gnome-btdownload/Makefile b/net-p2p/gnome-btdownload/Makefile
index dbed7070bbd2..d2dcd245550a 100644
--- a/net-p2p/gnome-btdownload/Makefile
+++ b/net-p2p/gnome-btdownload/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome-btdownload
-PORTVERSION= 0.0.11
-PORTREVISION= 1
+PORTVERSION= 0.0.16
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gnome-bt
@@ -15,21 +14,29 @@ MASTER_SITE_SUBDIR= gnome-bt
MAINTAINER= mezz@FreeBSD.org
COMMENT= A simple Gnome interface designed as a mime-sink for BitTorrent files
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/BitTorrent/__init__.py:${PORTSDIR}/net/py-bittorrent-core \
- ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/BitTorrent/__init__.py:${PORTSDIR}/net/py-bittorrent-core
USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix
+USE_GNOME= gnomehack gnomeprefix pygnome2
GNU_CONFIGURE= yes
MAN1= gnome-btdownload.1
+DOCS= AUTHORS COPYING ChangeLog INSTALL README
post-patch:
@${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/${PORTNAME}
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>