aboutsummaryrefslogtreecommitdiffstats
path: root/net/amule1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/amule1/Makefile')
-rw-r--r--net/amule1/Makefile34
1 files changed, 11 insertions, 23 deletions
diff --git a/net/amule1/Makefile b/net/amule1/Makefile
index 478895b7c86a..e98d75f36d97 100644
--- a/net/amule1/Makefile
+++ b/net/amule1/Makefile
@@ -19,26 +19,29 @@ LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
USE_X_PREFIX= yes
USE_GNOME= gnomehier gnomehack gnomeprefix
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext \
--with-libintl-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE} \
--with-wx-config=${WX_CONFIG} \
- --with-wxbase-config=${WX_CONFIG}
-
-OPTIONS= OPTIMIZE "Build with optimization" off \
- STATIC "Enable static linking" off \
- RELGRP "Use release group code" off
+ --with-wxbase-config=${WX_CONFIG} \
+ --with-curl-config=${CURL_CONFIG} \
+ --program-transform-name="s/ed2k/amule-ed2k-handler/"
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+OPTIONS= OPTIMIZE "Build with optimization" on \
+ STATIC "Enable static linking" off
+
WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+CURL_CONFIG?= ${LOCALBASE}/bin/curl-config
+
+.include <bsd.port.pre.mk>
# Configure options
-.if defined(WITH_OPTIMIZE)
+.if !defined(WITHOUT_OPTIMIZE)
CONFIGURE_ARGS+= --enable-optimise
.endif
@@ -46,19 +49,4 @@ CONFIGURE_ARGS+= --enable-optimise
CONFIGURE_ARGS+= --enable-static
.endif
-.if defined(WITH_RELGRP)
-CONFIGURE_ARGS+= --enable-releasegrp
-.endif
-
-post-build:
-# Build the generic named ed2k binary
-# It will be installed in an adhoc fashion
- @cd ${BUILD_WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ed2k
-
-post-install:
-# Do not install a generic named ed2k binary
-# Install it under a more specific name
- @${INSTALL_PROGRAM} ${WRKSRC}/src/ed2k \
- ${PREFIX}/bin/amule-ed2k-handler
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>