aboutsummaryrefslogtreecommitdiffstats
path: root/net/gtk-gnutella/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gtk-gnutella/Makefile')
-rw-r--r--net/gtk-gnutella/Makefile50
1 files changed, 26 insertions, 24 deletions
diff --git a/net/gtk-gnutella/Makefile b/net/gtk-gnutella/Makefile
index 70d8728fcb65..44cb2214d0fe 100644
--- a/net/gtk-gnutella/Makefile
+++ b/net/gtk-gnutella/Makefile
@@ -8,9 +8,10 @@
#
# A quick note on configurable make symbols:
#
-# WITH_INTERACTIVE: Launches Configure in it's default mode, which is *very*
-# interactive. Disabled here by default to conform to FreeBSD guidelines,
-# this mode is useful if you have problems with the default Configure.
+# INTERACTIVE_CONFIGURE: Launches Configure in it's default mode,
+# which is *very* interactive. Disabled here by default to conform to
+# FreeBSD guidelines, this mode is useful if you have problems with the
+# default Configure.
#
# WITH_GTK2: Configure and build for gtk2.
#
@@ -18,17 +19,15 @@
# at a cost in performance. Useful if you intend to move the executable
# to multiple machines.
#
-# WITH_DEBUG: Compile with debugging symbols. Useful if you intend to make a bug
-# report.
+# WITH_DEBUG: Compile with debugging symbols. Useful if you intend to make
+# a bug report.
#
-# Note that unicode support is currently unavailable for this platform. This
-# package requires a working ICU installation to achieve this, which doesn't
-# work here, and produces a broken executable.
+# WITHOUT_ICU: Don't compile with unicode support via the ICU library.
+# Note that ICU versions previous to 2.6 may not work correctly.
#
PORTNAME= gtk-gnutella
-PORTVERSION= 0.93.3
-PORTREVISION= 1
+PORTVERSION= 0.93.4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://gtk-gnutella.sourceforge.net/download/ \
@@ -39,14 +38,11 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= crollins666@hotmail.com
COMMENT= GTK based Gnutella client
-MAN1= gtk-gnutella.1
-
USE_PERL5= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_BISON= yes
USE_GNOME= libxml2
-USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX}
@@ -54,15 +50,21 @@ CONFIGURE_ARGS+= -Dbindir=${PREFIX}/bin -Dprivlib=${PREFIX}/share/gtk-gnutella
CONFIGURE_ARGS+= -Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale
CONFIGURE_ARGS+= -Dccflags='${CFLAGS} -I${LOCALBASE}/include/'
-OPTIONS= DEBUG "Build with debugging symbols" off\
+MAN1= gtk-gnutella.1
+
+OPTIONS= DEBUG "Build with debugging symbols" off \
GTK2 "Build with gtk2 frontend" off \
- INTERACTIVE "Use Configure in interactive mode" off \
+ ICU "Enable non-roman charset support" on \
PORTABILITY "Use the PATH variable at run-time" off
.include <bsd.port.pre.mk>
-.if !defined(WITH_INTERACTIVE)
-CONFIGURE_ARGS+=-d -e
+.if !defined(INTERACTIVE_CONFIGURE)
+CONFIGURE_ARGS+= -d -e
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= -Doptimize=-g -Uofficial=
.endif
.if defined(WITH_GTK2)
@@ -73,16 +75,16 @@ CONFIGURE_ARGS+= -Dgtkversion=1
USE_GNOME+= gtk12
.endif
-.if defined(WITH_PORTABILITY)
-CONFIGURE_ARGS+= -Dd_portable=true
-.endif
+.if !defined(WITHOUT_ICU)
+LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu2
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+= -Doptimize=-g -Uofficial=
+# Add threading to the ld flags; icuuc requires these by default
+CONFIGURE_ARGS+= -Dldflags=${PTHREAD_LIBS}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's| icuuc | |' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.if defined(WITH_PORTABILITY)
+CONFIGURE_ARGS+= -Dd_portable=true
+.endif
post-install:
@${ECHO} 'Installing compressed man page in man/man1/'